Upgrading web app to Flex 4.15

classic Classic list List threaded Threaded
19 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrading web app to Flex 4.15

olegkon
Hi,

We are trying to upgrade our Flex/BlazeDS4/Java8/Spring4 large web app
from Flex 4.6 to 4.15.
Getting a few issues:
1) compilation error on DropDownList:
1020: Method marked override must override another method.     OptgroupDropDownList.as  
// Override the setSelectedIndex() mx_internal method to not select an item that has selectionEnabled=false.
           
        override mx_internal function setSelectedIndex(value:int, dispatchChangeEvent:Boolean = false,
                                                                    changeCaret:Boolean=true):void

2) ant build takes Very long time (mostly in Flex compilation), much longer than before:
from 2 min went to 30 mins.

Please help.

TIA,
Oleg.
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

clintm
override mx_internal function setSelectedIndex
should be;
override public function setSelectedIndex //it's public now

ant build could be your java heap XMX… what's it set at?

paste the command you're using to run mxmlc

run ant with -d (e.g ant build -d)

what's your java -version say?

I'm running 1.7.0_79-b15


On Fri, Feb 3, 2017 at 8:11 AM, olegkon <[hidden email]> wrote:

> Hi,
>
> We are trying to upgrade our Flex/BlazeDS4/Java8/Spring4 large web app
> from Flex 4.6 to 4.15.
> Getting a few issues:
> 1) compilation error on DropDownList:
> 1020: Method marked override must override another method.
> OptgroupDropDownList.as
> // Override the setSelectedIndex() mx_internal method to not select an item
> that has selectionEnabled=false.
>
>         override mx_internal function setSelectedIndex(value:int,
> dispatchChangeEvent:Boolean = false,
>
> changeCaret:Boolean=true):void
>
> 2) ant build takes Very long time (mostly in Flex compilation), much longer
> than before:
> from 2 min went to 30 mins.
>
> Please help.
>
> TIA,
> Oleg.
>
>
>
> --
> View this message in context: http://apache-flex-users.
> 2333346.n4.nabble.com/Upgrading-web-app-to-Flex-4-15-tp14603.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

olegkon
Clint,

We will try your suggestion and let you know.

java.runtime.version -> 1.8.0_111-b14
using:   -Xmx256m


Thanks,
Oleg.
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

olegkon
Clint,

1) I tried what you suggested:
override public function setSelectedIndex(value:int, dispatchChangeEvent:Boolean = false,   changeCaret:Boolean=true):void {  ... }

When I try to save it, getting compilation error:   Method marked override must override another method.
So I removed override from there, that worked.


2) actually now compilation takes even longer - about 2 hours (!) on a good PC with 16GB of RAM and SSD,
most of it in compile modules task.
Why is it so terribly slow?


3) Also, can we get a source code of flexTasks.jar (for 4.15)?


4) Also we are trying to use FSCH to compile that Flex project faster, but can only see one for Flex3.
Is there a more recent one?   Or you think it is not a good idea with 4.15?
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

olegkon
4)  FCSH (corrected) - is it worth using with Flex 4.15?
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

olegkon
4) when running Ant with FCSH second time getting issue:
Files: 448 Time: 413ms
Total time: 12344ms
Peak memory usage: 271 MB (Heap: 226, Non-Heap: 45)
(fcsh) -------------------[BUILD FAILED]-------------------
(fcsh) compile 1
Loading configuration file C:\Apps\flex\4.15\frameworks\flex-config.xml
Initial setup: 80227ms
start loading swcs 1ms Running Total: 92571ms
Loaded 52 SWCs: 174ms
Nothing has changed since the last compile. Skip...
Total time: 94018ms
Peak memory usage: 210 MB (Heap: 163, Non-Heap: 47)
Linking... 1412ms
 Error: null
 Total time: 1447ms

Peak memory usage: 300 MB (Heap: 253, Non-Heap: 47)
(fcsh) -------------------[BUILD FAILED]-------------------
[ERROR] No target was selected for removal
[ERROR] No target was selected for recompile

Is there a more recent version of Ant - FCSH integration available for 4.15?
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

clintm
In reply to this post by olegkon
Inline below

On Tue, Feb 7, 2017 at 7:49 AM, olegkon <[hidden email]> wrote:

> Clint,
>
> 1) I tried what you suggested:
> override public function setSelectedIndex(value:int,
> dispatchChangeEvent:Boolean = false,
> changeCaret:Boolean=true):void {  ... }


> When I try to save it, getting compilation error:   Method marked override
> must override another method.
> So I removed override from there, that worked.
>

I'm not sure you want to remove that. I'm also not sure why it didn't work
for you. You can view the source the method is public now.

From DropDownListBase.as
override public function setSelectedIndex(rowIndex:int,
dispatchChangeEvent:Boolean = false, changeCaret:Boolean = true):void


>
> 2) actually now compilation takes even longer - about 2 hours (!) on a good
> PC with 16GB of RAM and SSD,
> most of it in compile modules task.
> Why is it so terribly slow?
>

What is your Xmx set at?


>
>
> 3) Also, can we get a source code of flexTasks.jar (for 4.15)?
>

I don't think so but I'm not sure.  You could decompile it if you want.
What do you get when you run it with -d ?(eg. ant build -d)

This will give you the exact command that you could run on the command line
instead of using the ant tasks.


>
>
> 4) Also we are trying to use FSCH to compile that Flex project faster, but
> can only see one for Flex3.
> Is there a more recent one?   Or you think it is not a good idea with 4.15?
>


 Should work as long as you understand the speed boost is from:

a) not booting up the jvm everytime
b) incremental compilation is faster because it keeps a cache

If you're running ant… there's a good chance you don't want b) in the first
place and just want a clean build everytime.


>
>
>
> --
> View this message in context: http://apache-flex-users.
> 2333346.n4.nabble.com/Upgrading-web-app-to-Flex-4-15-tp14603p14637.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

clintm
In reply to this post by olegkon
fcsh is in the sdk
$FLEX_HOME/lib/fcsh.jar
and
$FLEX_HOME/bin/fcsh(.bat on win) <--wrapper script for the jar

On Tue, Feb 7, 2017 at 8:21 AM, olegkon <[hidden email]> wrote:

> 4) when running Ant with FCSH second time getting issue:
> Files: 448 Time: 413ms
> Total time: 12344ms
> Peak memory usage: 271 MB (Heap: 226, Non-Heap: 45)
> (fcsh) -------------------[BUILD FAILED]-------------------
> (fcsh) compile 1
> Loading configuration file C:\Apps\flex\4.15\frameworks\flex-config.xml
> Initial setup: 80227ms
> start loading swcs 1ms Running Total: 92571ms
> Loaded 52 SWCs: 174ms
> Nothing has changed since the last compile. Skip...
> Total time: 94018ms
> Peak memory usage: 210 MB (Heap: 163, Non-Heap: 47)
> Linking... 1412ms
>  Error: null
>  Total time: 1447ms
>
> Peak memory usage: 300 MB (Heap: 253, Non-Heap: 47)
> (fcsh) -------------------[BUILD FAILED]-------------------
> [ERROR] No target was selected for removal
> [ERROR] No target was selected for recompile
>
> Is there a more recent version of Ant - FCSH integration available for
> 4.15?
>
>
>
>
> --
> View this message in context: http://apache-flex-users.
> 2333346.n4.nabble.com/Upgrading-web-app-to-Flex-4-15-tp14603p14639.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

olegkon
In reply to this post by clintm
1) Actually it still did not compile, failed after almost 2 hours with:
C:\web\cre\ui\flex\main\com\opera\mobiuss\cre\common\components\OptgroupDropDownList\OptgroupDropDownList.as(22): col: 25 Error: Overriding a function that is not marked for override.
    [mxmlc]
       public function setSelectedIndex(value:int, dispatchChangeEvent:Boolean = false,...
And if I add override and save, get:   Method marked override must override another method.
Note:  have that specified:      use namespace mx_internal;
I also have that in the same class (maybe that effects it?):
override mx_internal function setSelectedIndices(value:Vector.<int>, dispatchChangeEvent:Boolean = false, changeCaret:Boolean=true):void {...}
override protected function keyDownHandler(event:KeyboardEvent) : void {...}

2)  
>What is your Xmx set at?
-Xms512m
-Xmx2048m
-XX:MaxPermSize2048m

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

clintm
Are you able to post the output of the following?

ant [yourBuildTarget] -d

On Tue, Feb 7, 2017 at 11:23 AM, olegkon <[hidden email]> wrote:

> 1) Actually it still did not compile, failed after almost 2 hours with:
> C:\web\cre\ui\flex\main\com\opera\mobiuss\cre\common\components\
> OptgroupDropDownList\OptgroupDropDownList.as(22):
> col: 25 Error: Overriding a function that is not marked for override.
>     [mxmlc]
>        public function setSelectedIndex(value:int,
> dispatchChangeEvent:Boolean = false,...
> And if I add override and save, get:   Method marked override must override
> another method.
> Note:  have that specified:      use namespace mx_internal;
> I also have that in the same class (maybe that effects it?):
> override mx_internal function setSelectedIndices(value:Vector.<int>,
> dispatchChangeEvent:Boolean = false, changeCaret:Boolean=true):void {...}
> override protected function keyDownHandler(event:KeyboardEvent) : void
> {...}
>
> 2)
> >What is your Xmx set at?
> -Xms512m
> -Xmx2048m
> -XX:MaxPermSize2048m
>
>
>
>
>
> --
> View this message in context: http://apache-flex-users.
> 2333346.n4.nabble.com/Upgrading-web-app-to-Flex-4-15-tp14603p14642.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

Alex Harui
In reply to this post by olegkon


On 2/7/17, 11:23 AM, "olegkon" <[hidden email]> wrote:

>1) Actually it still did not compile, failed after almost 2 hours with:
>C:\web\cre\ui\flex\main\com\opera\mobiuss\cre\common\components\OptgroupDr
>opDownList\OptgroupDropDownList.as(22):
>col: 25 Error: Overriding a function that is not marked for override.
>    [mxmlc]
>       public function setSelectedIndex(value:int,
>dispatchChangeEvent:Boolean = false,...
>And if I add override and save, get:   Method marked override must
>override
>another method.
>Note:  have that specified:      use namespace mx_internal;
>I also have that in the same class (maybe that effects it?):
>override mx_internal function setSelectedIndices(value:Vector.<int>,
>dispatchChangeEvent:Boolean = false, changeCaret:Boolean=true):void {...}
>override protected function keyDownHandler(event:KeyboardEvent) : void
>{...}

Makes me think you are still compiling with old SWCs in the library-path.

If it is taking 2 hours, try turning off your virus scanners and/or do a
disk check for bad sectors.

-Alex

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

jmclean
Administrator
In reply to this post by olegkon
Hi,

> 2) ant build takes Very long time (mostly in Flex compilation), much longer
> than before:
> from 2 min went to 30 mins.

This seems quite unusual and certainly not the experience I’ve had when converting projects. Not much has changed in the compilers over that time (it’s mostly been framework changes) other than a couple of options added. (e.g. advanced telemetry)

You might want to try using a more modern version of Java (1.7 or 1.8) if you’re not I find that speeds up compile times, but I’d guess there’s something else amiss here.

Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

olegkon
In reply to this post by clintm
Clint,

Here is an exerpt of the last few lines of  ant -d:

   [mxmlc] FlexTask.execute: -compiler.keep-generated-actionscript=true -compiler.incremental=true "+flexlib=C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\4.15/frameworks" -compiler.actionscript-file-encoding=UTF-8 -load-externs=report.xml "-load-config=C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\4.15/frameworks/flex-config.xml" -compiler.keep-as3-metadata=Inject -compiler.keep-as3-metadata=PostConstruct -compiler.debug=true "-compiler.source-path=C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\4.15/frameworks" -compiler.source-path=../ui/flex/main/ -compiler.source-path=../ui/flex/assets/ -use-network=true -compiler.include-libraries+=C:\myapp\flex\libs\AlivePDF.swc -compiler.include-libraries+=C:\myapp\flex\libs\SwiftSuspenders-v1.6.0.swc -compiler.include-libraries+=C:\myapp\flex\libs\fds.swc -compiler.include-libraries+=C:\myapp\flex\libs\fds_rb.swc -compiler.include-libraries+=C:\web\cre\ui\flex\libs\fiber.swc -compiler.include-libraries+=C:\myapp\flex\libs\fiber_rb.swc -compiler.include-libraries+=C:\myapp\flex\libs\flex-iframe-1.4.6.swc -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-flex-core.swc -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-flex-data.swc -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-flex-visualizations.swc -compiler.include-libraries+=C:\myapp\flex\libs\playerfds.swc -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-framework-v1.5.2.swc -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-utilities-Modular-v0.5.3.swc -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-utilities-StateMachine.swc -compiler.include-libraries+=C:\myapp\flex\libs\serializers.swc -compiler.include-libraries+=C:\myapp\flex\libs\serializers_rb.swc -output=C:\myapp\map\Map.swf -- ../myapp/map/Map.mxml
    [mxmlc] Loading configuration file C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\4.15\frameworks\flex-config.xml
    [mxmlc] C:\myapp\map\Map.swf.cache (The system cannot find the file specified)
    [mxmlc] C:\myapp\OptgroupDropDownList\OptgroupDropDownList.as(22): col: 21 Error: Overriding a function that is not marked for override.
    [mxmlc]
    [mxmlc]     public function setSelectedIndex(value:int, dispatchChangeEvent:Boolean = false,
    [mxmlc]                     ^
    [mxmlc]

BUILD FAILED

We have old SWCs for libraries we are using.
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

Josh Tynjala
I assume that some or all of those SWCs were compiled with an older version
of the Flex SDK. That's not necessarily going to break things on its own.
However, if the Flex framework was accidentally specified on the
library-path instead of the external-library-path, that would cause parts
of the Flex framework to be included in the SWC, which could conflict with
the newer SDK.

- Josh

On Wed, Feb 8, 2017 at 10:29 AM, olegkon <[hidden email]> wrote:

> Clint,
>
> Here is an exerpt of the last few lines of  ant -d:
>
>    [mxmlc] FlexTask.execute: -compiler.keep-generated-actionscript=true
> -compiler.incremental=true "+flexlib=C:\Program Files\Adobe\Adobe Flash
> Builder 4.7 (64 Bit)\sdks\4.15/frameworks"
> -compiler.actionscript-file-encoding=UTF-8 -load-externs=report.xml
> "-load-config=C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64
> Bit)\sdks\4.15/frameworks/flex-config.xml"
> -compiler.keep-as3-metadata=Inject -compiler.keep-as3-metadata=
> PostConstruct
> -compiler.debug=true "-compiler.source-path=C:\Program Files\Adobe\Adobe
> Flash Builder 4.7 (64 Bit)\sdks\4.15/frameworks"
> -compiler.source-path=../ui/flex/main/
> -compiler.source-path=../ui/flex/assets/ -use-network=true
> -compiler.include-libraries+=C:\myapp\flex\libs\AlivePDF.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\SwiftSuspenders-v1.6.0.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\fds.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\fds_rb.swc
> -compiler.include-libraries+=C:\web\cre\ui\flex\libs\fiber.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\fiber_rb.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\flex-iframe-1.4.6.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-flex-core.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-flex-data.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-
> flex-visualizations.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\playerfds.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-
> framework-v1.5.2.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-
> utilities-Modular-v0.5.3.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-
> utilities-StateMachine.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\serializers.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\serializers_rb.swc
> -output=C:\myapp\map\Map.swf -- ../myapp/map/Map.mxml
>     [mxmlc] Loading configuration file C:\Program Files\Adobe\Adobe Flash
> Builder 4.7 (64 Bit)\sdks\4.15\frameworks\flex-config.xml
>     [mxmlc] C:\myapp\map\Map.swf.cache (The system cannot find the file
> specified)
>     [mxmlc] C:\myapp\OptgroupDropDownList\OptgroupDropDownList.as(22):
> col:
> 21 Error: Overriding a function that is not marked for override.
>     [mxmlc]
>     [mxmlc]     public function setSelectedIndex(value:int,
> dispatchChangeEvent:Boolean = false,
>     [mxmlc]                     ^
>     [mxmlc]
>
> BUILD FAILED
>
> We have old SWCs for libraries we are using.
>
>
>
> --
> View this message in context: http://apache-flex-users.
> 2333346.n4.nabble.com/Upgrading-web-app-to-Flex-4-15-tp14603p14653.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

clintm
In reply to this post by olegkon
this part might take some time… -compiler.keep-generated-actionscript=true

On Wed, Feb 8, 2017 at 10:29 AM, olegkon <[hidden email]> wrote:

> Clint,
>
> Here is an exerpt of the last few lines of  ant -d:
>
>    [mxmlc] FlexTask.execute: -compiler.keep-generated-actionscript=true
> -compiler.incremental=true "+flexlib=C:\Program Files\Adobe\Adobe Flash
> Builder 4.7 (64 Bit)\sdks\4.15/frameworks"
> -compiler.actionscript-file-encoding=UTF-8 -load-externs=report.xml
> "-load-config=C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64
> Bit)\sdks\4.15/frameworks/flex-config.xml"
> -compiler.keep-as3-metadata=Inject -compiler.keep-as3-metadata=
> PostConstruct
> -compiler.debug=true "-compiler.source-path=C:\Program Files\Adobe\Adobe
> Flash Builder 4.7 (64 Bit)\sdks\4.15/frameworks"
> -compiler.source-path=../ui/flex/main/
> -compiler.source-path=../ui/flex/assets/ -use-network=true
> -compiler.include-libraries+=C:\myapp\flex\libs\AlivePDF.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\SwiftSuspenders-v1.6.0.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\fds.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\fds_rb.swc
> -compiler.include-libraries+=C:\web\cre\ui\flex\libs\fiber.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\fiber_rb.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\flex-iframe-1.4.6.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-flex-core.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-flex-data.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-
> flex-visualizations.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\playerfds.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-
> framework-v1.5.2.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-
> utilities-Modular-v0.5.3.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-
> utilities-StateMachine.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\serializers.swc
> -compiler.include-libraries+=C:\myapp\flex\libs\serializers_rb.swc
> -output=C:\myapp\map\Map.swf -- ../myapp/map/Map.mxml
>     [mxmlc] Loading configuration file C:\Program Files\Adobe\Adobe Flash
> Builder 4.7 (64 Bit)\sdks\4.15\frameworks\flex-config.xml
>     [mxmlc] C:\myapp\map\Map.swf.cache (The system cannot find the file
> specified)
>     [mxmlc] C:\myapp\OptgroupDropDownList\OptgroupDropDownList.as(22):
> col:
> 21 Error: Overriding a function that is not marked for override.
>     [mxmlc]
>     [mxmlc]     public function setSelectedIndex(value:int,
> dispatchChangeEvent:Boolean = false,
>     [mxmlc]                     ^
>     [mxmlc]
>
> BUILD FAILED
>
> We have old SWCs for libraries we are using.
>
>
>
> --
> View this message in context: http://apache-flex-users.
> 2333346.n4.nabble.com/Upgrading-web-app-to-Flex-4-15-tp14603p14653.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

Alex Harui
In reply to this post by Josh Tynjala
I just realized that compiler.include-libraries is being used instead of
-compiler.library-path.

Is that on purpose?

-Alex

On 2/8/17, 10:38 AM, "Josh Tynjala" <[hidden email]> wrote:

>I assume that some or all of those SWCs were compiled with an older
>version
>of the Flex SDK. That's not necessarily going to break things on its own.
>However, if the Flex framework was accidentally specified on the
>library-path instead of the external-library-path, that would cause parts
>of the Flex framework to be included in the SWC, which could conflict with
>the newer SDK.
>
>- Josh
>
>On Wed, Feb 8, 2017 at 10:29 AM, olegkon <[hidden email]> wrote:
>
>> Clint,
>>
>> Here is an exerpt of the last few lines of  ant -d:
>>
>>    [mxmlc] FlexTask.execute: -compiler.keep-generated-actionscript=true
>> -compiler.incremental=true "+flexlib=C:\Program Files\Adobe\Adobe Flash
>> Builder 4.7 (64 Bit)\sdks\4.15/frameworks"
>> -compiler.actionscript-file-encoding=UTF-8 -load-externs=report.xml
>> "-load-config=C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64
>> Bit)\sdks\4.15/frameworks/flex-config.xml"
>> -compiler.keep-as3-metadata=Inject -compiler.keep-as3-metadata=
>> PostConstruct
>> -compiler.debug=true "-compiler.source-path=C:\Program Files\Adobe\Adobe
>> Flash Builder 4.7 (64 Bit)\sdks\4.15/frameworks"
>> -compiler.source-path=../ui/flex/main/
>> -compiler.source-path=../ui/flex/assets/ -use-network=true
>> -compiler.include-libraries+=C:\myapp\flex\libs\AlivePDF.swc
>>
>>-compiler.include-libraries+=C:\myapp\flex\libs\SwiftSuspenders-v1.6.0.sw
>>c
>> -compiler.include-libraries+=C:\myapp\flex\libs\fds.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\fds_rb.swc
>> -compiler.include-libraries+=C:\web\cre\ui\flex\libs\fiber.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\fiber_rb.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\flex-iframe-1.4.6.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-flex-core.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-flex-data.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\juicekit-
>> flex-visualizations.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\playerfds.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-
>> framework-v1.5.2.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-
>> utilities-Modular-v0.5.3.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\robotlegs-
>> utilities-StateMachine.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\serializers.swc
>> -compiler.include-libraries+=C:\myapp\flex\libs\serializers_rb.swc
>> -output=C:\myapp\map\Map.swf -- ../myapp/map/Map.mxml
>>     [mxmlc] Loading configuration file C:\Program Files\Adobe\Adobe
>>Flash
>> Builder 4.7 (64 Bit)\sdks\4.15\frameworks\flex-config.xml
>>     [mxmlc] C:\myapp\map\Map.swf.cache (The system cannot find the file
>> specified)
>>     [mxmlc] C:\myapp\OptgroupDropDownList\OptgroupDropDownList.as(22):
>> col:
>> 21 Error: Overriding a function that is not marked for override.
>>     [mxmlc]
>>     [mxmlc]     public function setSelectedIndex(value:int,
>> dispatchChangeEvent:Boolean = false,
>>     [mxmlc]                     ^
>>     [mxmlc]
>>
>> BUILD FAILED
>>
>> We have old SWCs for libraries we are using.
>>
>>
>>
>> --
>> View this message in context: http://apache-flex-users.
>> 2333346.n4.nabble.com/Upgrading-web-app-to-Flex-4-15-tp14603p14653.html
>> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>>

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

olegkon
Alex,
I am not sure of its purpose.  Original developers of that project long gone, no docs...
What does it affect?

Changing it probably will have no significant effect on the compilation speed.  

As I said, it was compiling in 2 mins with 4.6.0 before (with all same settings).
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

Alex Harui


On 2/8/17, 11:45 AM, "olegkon" <[hidden email]> wrote:

>Alex,
>I am not sure of its purpose.  Original developers of that project long
>gone, no docs...
>What does it affect?

I think it copied entire SWCs into the output, but that should not be
necessary.  Try switching to -compiler.library-path and see what happens.
At least that will eliminate use of include-libraries as part of either
issue.

BTW, if you can still compile with 4.6.0, try seeing what memory
consumption looks like in the Task Manager or some other tool, then
compare it to 4.15.0.  Another possibility is that 4.15.0 is now using
64-bit and 4.6 was 32-bit, and now you are thrashing.

HTH,
-Alex

Reply | Threaded
Open this post in threaded view
|

Re: Upgrading web app to Flex 4.15

Nemi
In reply to this post by olegkon
If ant build takes longer, try setting higher maxmemory, for example 2GB:
<mxmlc maxmemory="2048m">