Trying to use iOS Simulator: library not found for -lstdc++

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Trying to use iOS Simulator: library not found for -lstdc++

Erik J. Thomas
I am trying to use the iOS Simulator that comes with XCode and can't get it working. ADT command completes no problem when targeting a device, and the emulator works as well, but I'm getting this error when trying to run in iOS Simulator:

ld: library not found for -lstdc++
Compilation failed while executing : ld64

ADT command line:
/Applications/IntelliJ IDEA 2018.2.app/Contents/jdk/Contents/Home/jre/bin/java -Dapplication.home=/Users/ethomas/linqto/FlexSDKs/SDK4.16.1-31-42 -Dfile.encoding=UTF-8 -Djava.awt.headless=true -Duser.language=en -Duser.region=en -Xmx1024m -jar /Users/ethomas/linqto/FlexSDKs/SDK4.16.1-31-42/lib/adt.jar -package -target ipa-debug-interpreter-simulator -storetype PKCS12 -keystore /Applications/IntelliJ IDEA 2018.2.app/Contents/plugins/flex/lib/temp_keystore.p12 -storepass keystore_password /Users/ethomas/linqto/FlexDev/keiretsu/out/production/keiretsu/keiretsuforum.ipa /Users/ethomas/linqto/FlexDev/keiretsu/out/production/keiretsu/keiretsu-app.xml -platformsdk /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk -extdir /Users/ethomas/linqto/FlexDev/EventANE -C /Users/ethomas/linqto/FlexDev/keiretsu/out/production/keiretsu Main.swf -C /Users/ethomas/linqto/FlexDev/keiretsu/appicons . -C /Users/ethomas/linqto/FlexDev/keiretsu linqto.json -C /Users/ethomas/linqto/FlexDev/keiretsu/launchscreens . -C /Users/ethomas/linqto/FlexDev/keiretsu Assets.car

I can launch the XCode iOS simulator app directly no problem but can't get my flex app to run in it.

Any ideas?

Thanks in advance!

Erik

Reply | Threaded
Open this post in threaded view
|

Re: Trying to use iOS Simulator: library not found for -lstdc++

Prabhu Moorthy
Ref:
https://helpx.adobe.com/in/flash-player/release-note/fp_32_air_32_release_notes.html

iOS SDK Upgrade
AIR Runtime is now built with iOS 12 SDK, which enables AIR developers to
use ANEs built with iOS 12 APIs without using the –platformSDK switch while
packaging with ADT.

To use existing ANEs built with earlier iOS version:

Apple has removed support for libstdc++ from Xcode10 (iOS12). All the native
static libraries used in ANE, which are built with libstdc++ will not work
with the latest AIR SDK. It will throw the below error. The static library
has to be rebuilt with Xcode 10 and repackaged.
Error : ld: library not found for -lstdc++
ld: library not found for -lstdc++
Compilation failed while executing : ld64
We have updated some of the symbols in the stub files generated, which are
in accordance with Apple’s changes. If you see below error during packaging
ipa with ANE, repackage the ANE with the latest AIR SDK.
Error: Undefined symbols for architecture armv7/arm64
If we are using -platformsdk, we need to replace the ld from
/Applications/Xcode-beta.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin
to /AIRSDK/lib/aot/bin/ld64/ld64 and rename it to ld64.
While using -platformsdk, developers must specify the iphoneOS version
number 12.0 in the path to avoid any unintended behavior. For example,
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS12.0.sdk



-----
Thanks & Regards,
M.Prabhu
--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Thanks & Regards,
M.Prabhu
Reply | Threaded
Open this post in threaded view
|

Re: Trying to use iOS Simulator: library not found for -lstdc++

Erik Thomas
Thank you Prabhu.