SDK Version Issue for iOS

classic Classic list List threaded Threaded
20 messages Options
Reply | Threaded
Open this post in threaded view
|

SDK Version Issue for iOS

Erik J. Thomas
Anyone else run into this error from Apple when uploading an app?

"SDK Version Issue - This app was built with the iOS 12.0 SDK. Starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later."

I built this app with the latest AIR SDK 32.

Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Erik J. Thomas
Well, the release notes for AIR 32 claim it uses iOS 12.1 so this must be related to some of my ANEs.

Can anyone verify this error goes away with AIR 32 (if you have no ANEs or have recompiled your ANEs with iOS SDK 12.1?

Thanks.

Erik

On Mar 5, 2019, at 4:15 PM, Erik J. Thomas <[hidden email]> wrote:

Anyone else run into this error from Apple when uploading an app?

"SDK Version Issue - This app was built with the iOS 12.0 SDK. Starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later."

I built this app with the latest AIR SDK 32.


Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Erik J. Thomas
Has nobody else on this forum encountered this issue? Do none of you create iOS mobile apps with AIR? I'm still waiting on an answer from our ANE provider but we're receiving the 12.1 warning on our app uploads and figure it must be our ANEs that may not be up-to-date.

Just looking for a clue. Thanks.

Erik

On Mar 6, 2019, at 10:54 AM, Erik J. Thomas <[hidden email]> wrote:

Well, the release notes for AIR 32 claim it uses iOS 12.1 so this must be related to some of my ANEs.

Can anyone verify this error goes away with AIR 32 (if you have no ANEs or have recompiled your ANEs with iOS SDK 12.1?

Thanks.

Erik

On Mar 5, 2019, at 4:15 PM, Erik J. Thomas <[hidden email]> wrote:

Anyone else run into this error from Apple when uploading an app?

"SDK Version Issue - This app was built with the iOS 12.0 SDK. Starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later."

I built this app with the latest AIR SDK 32.




Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Alex Harui-2
Erik,

Have you contacted the Adobe AIR team?

-Alex

On 3/8/19, 8:28 AM, "Erik J. Thomas" <[hidden email]> wrote:

    Has nobody else on this forum encountered this issue? Do none of you create iOS mobile apps with AIR? I'm still waiting on an answer from our ANE provider but we're receiving the 12.1 warning on our app uploads and figure it must be our ANEs that may not be up-to-date.
   
    Just looking for a clue. Thanks.
   
    Erik
   
    On Mar 6, 2019, at 10:54 AM, Erik J. Thomas <[hidden email]> wrote:
   
    Well, the release notes for AIR 32 claim it uses iOS 12.1 so this must be related to some of my ANEs.
   
    Can anyone verify this error goes away with AIR 32 (if you have no ANEs or have recompiled your ANEs with iOS SDK 12.1?
   
    Thanks.
   
    Erik
   
    On Mar 5, 2019, at 4:15 PM, Erik J. Thomas <[hidden email]> wrote:
   
    Anyone else run into this error from Apple when uploading an app?
   
    "SDK Version Issue - This app was built with the iOS 12.0 SDK. Starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later."
   
    I built this app with the latest AIR SDK 32.
   
   
   
   
   

Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Erik Thomas
This thread explains the issue, and apparently AIR 32 really does fix this problem:

https://forums.adobe.com/thread/2582887 <https://forums.adobe.com/thread/2582887>

So I guess it's the ANEs I'm using. I've contacted Distriqt but haven't yet heard back. I reviewed the github checkin comments and last updated dates, and it appears they have not yet been compiled with 12.1. That is most likely the issue. I will confirm the ANEs are built with 12.1 before I contact AIR team.

Thanks for responding, Alex.

Erik

On Mar 8, 2019, at 9:14 AM, Alex Harui <[hidden email]> wrote:

Erik,

Have you contacted the Adobe AIR team?

-Alex

On 3/8/19, 8:28 AM, "Erik J. Thomas" <[hidden email]> wrote:

   Has nobody else on this forum encountered this issue? Do none of you create iOS mobile apps with AIR? I'm still waiting on an answer from our ANE provider but we're receiving the 12.1 warning on our app uploads and figure it must be our ANEs that may not be up-to-date.

   Just looking for a clue. Thanks.

   Erik

   On Mar 6, 2019, at 10:54 AM, Erik J. Thomas <[hidden email]> wrote:

   Well, the release notes for AIR 32 claim it uses iOS 12.1 so this must be related to some of my ANEs.

   Can anyone verify this error goes away with AIR 32 (if you have no ANEs or have recompiled your ANEs with iOS SDK 12.1?

   Thanks.

   Erik

   On Mar 5, 2019, at 4:15 PM, Erik J. Thomas <[hidden email]> wrote:

   Anyone else run into this error from Apple when uploading an app?

   "SDK Version Issue - This app was built with the iOS 12.0 SDK. Starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later."

   I built this app with the latest AIR SDK 32.







Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Kerogi
Eric, just released the app with following Distriqt ANEs and latest AIR
32.0.0.103.
<extensionID>com.distriqt.Core</extensionID>

        <extensionID>com.distriqt.Firebase</extensionID>

        <extensionID>com.distriqt.PushNotifications</extensionID>

        <extensionID>com.distriqt.Location</extensionID>

        <extensionID>com.distriqt.firebase.Auth</extensionID>
        <extensionID>com.distriqt.GoogleIdentity</extensionID>

        <extensionID>com.distriqt.FacebookAPI</extensionID>
        <extensionID>com.distriqt.Bolts</extensionID>

        <extensionID>com.distriqt.Scanner</extensionID>

        <extensionID>com.distriqt.NetworkInfo</extensionID>
        <extensionID>com.distriqt.Application</extensionID>

        <extensionID>com.distriqt.firebase.Database</extensionID>

Just letting know upload was fine without any warnings. Hope this can help
you to look at other possible issues.



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Erik Thomas
Found the problem.

Turns out the latest Flex 4.16.1 installer (as of last week) installs an older build of AIR SDK 32 that does not contain this fix:

The installer installed this version of AIR:

32.0.0.89

But the iOS 12.1 SDK wasn't put into the AIR SDK until this build:

32.0.0.103

Is there a plan to update the latest Flex SDK installer to include build 103 with the fix? While I understand I can update AIR myself with ANT, I'd prefer to use the installer if it's going to be updated.

Thanks.

Erik

On Mar 9, 2019, at 11:16 AM, Kerogi <[hidden email]> wrote:

Eric, just released the app with following Distriqt ANEs and latest AIR
32.0.0.103.
<extensionID>com.distriqt.Core</extensionID>

       <extensionID>com.distriqt.Firebase</extensionID>

       <extensionID>com.distriqt.PushNotifications</extensionID>

       <extensionID>com.distriqt.Location</extensionID>

       <extensionID>com.distriqt.firebase.Auth</extensionID>
       <extensionID>com.distriqt.GoogleIdentity</extensionID>

       <extensionID>com.distriqt.FacebookAPI</extensionID>
       <extensionID>com.distriqt.Bolts</extensionID>

       <extensionID>com.distriqt.Scanner</extensionID>

       <extensionID>com.distriqt.NetworkInfo</extensionID>
       <extensionID>com.distriqt.Application</extensionID>

       <extensionID>com.distriqt.firebase.Database</extensionID>

Just letting know upload was fine without any warnings. Hope this can help
you to look at other possible issues.



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/


Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Lydecker
Hi - can someone please let me know how to use ANT (what's the command line
to run) to get FLEX with AIR build 103?

I Used the SDK installer to get build 89, then manually downloaded "AIR 32
SDK for Flex Developers Build 103". I copied the contents of that directory
on-top of the AIR Flex SDK installer build 89 - whilst it compiled fine, it
still thinks it's linked against iOS12.0 when I submit to apple and I am
getting the warning about needing to be linked against iOS12.1 :(

Thanks





--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Lydecker
Well I thought this would work:
ant -f installer.xml -Dair.sdk.url.server=http://labsdownload.adobe.com
-Dair.sdk.url.folder=pub/labs/flashruntimes/air
-Dair.sdk.url.file=AdobeAIRSDK.zip


If I run it I get errors, but then if I run it again, it succeeds.

Anywho - it seems the copying on top of the old AIR works fine - I just
forgot to change the AIR target folder in my ADT command to reflect the nee
103 build. Uploads to iTunesConnect with no warning now fine.



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

bilbosax
Sorry Erik, I am just now seeing this post.  I had the exact same issue and
posted a question about it over on the Adobe AIR forum.  Apparently, the
Apache installer uses and older AIR 32 release.  When I installed AIR 32
directly from Adobe, it included the 12.1 SDK, and problem was solved.



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Erik Thomas
Thanks, Bill. So just copying the new AIR SDK over the existing Flex SDK directory that contains the AIR SDK installed from the installer works?
Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

bilbosax
Yes, absolutely



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Erik Thomas
In reply to this post by Kerogi
Do you know where I can download the AIR SDK (build 103)? I am searching and can only find the older build for download. Thanks!

Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

bilbosax
This is the post on Adobe where I asked the same question:

https://forums.adobe.com/thread/2597960

I was directed to use the AIR 32 Beta that had been updated since AIR 32 was
added to the Apache installer

https://labs.adobe.com/downloads/air.html


It worked for me like a charm.  No issues so far.



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

piotrz
Hi Guys,

In other words this build 103 wasn't released yet ?

Thanks,
Piotr

wt., 12 mar 2019 o 00:58 bilbosax <[hidden email]> napisał(a):

> This is the post on Adobe where I asked the same question:
>
> https://forums.adobe.com/thread/2597960
>
> I was directed to use the AIR 32 Beta that had been updated since AIR 32
> was
> added to the Apache installer
>
> https://labs.adobe.com/downloads/air.html
>
>
> It worked for me like a charm.  No issues so far.
>
>
>
> --
> Sent from: http://apache-flex-users.2333346.n4.nabble.com/
>


--

Piotr Zarzycki

Patreon: *https://www.patreon.com/piotrzarzycki
<https://www.patreon.com/piotrzarzycki>*
Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

piotrz
Never mind. I miss last email and see that is beta still.

wt., 12 mar 2019 o 09:41 Piotr Zarzycki <[hidden email]>
napisał(a):

> Hi Guys,
>
> In other words this build 103 wasn't released yet ?
>
> Thanks,
> Piotr
>
> wt., 12 mar 2019 o 00:58 bilbosax <[hidden email]> napisał(a):
>
>> This is the post on Adobe where I asked the same question:
>>
>> https://forums.adobe.com/thread/2597960
>>
>> I was directed to use the AIR 32 Beta that had been updated since AIR 32
>> was
>> added to the Apache installer
>>
>> https://labs.adobe.com/downloads/air.html
>>
>>
>> It worked for me like a charm.  No issues so far.
>>
>>
>>
>> --
>> Sent from: http://apache-flex-users.2333346.n4.nabble.com/
>>
>
>
> --
>
> Piotr Zarzycki
>
> Patreon: *https://www.patreon.com/piotrzarzycki
> <https://www.patreon.com/piotrzarzycki>*
>


--

Piotr Zarzycki

Patreon: *https://www.patreon.com/piotrzarzycki
<https://www.patreon.com/piotrzarzycki>*
Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Erik Thomas
Sorry to ask an old question again, but I copied the 103 build over my current FlexSDK directory created with the Flex SDK installer last week and it has hosed my builds:

Error:[EventCommons]: java.lang.NoClassDefFoundError: flex2/tools/VersionInfo
        at com.intellij.flex.compiler.FlexCompiler.<clinit>(FlexCompiler.java:19)
Caused by: java.lang.ClassNotFoundException: flex2.tools.VersionInfo
        at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        ... 1 more

Is there some second step needed when overlaying a new AIR SDK over existing Flex/AIR SDK directory?

Thanks.

On Mar 12, 2019, at 1:43 AM, Piotr Zarzycki <[hidden email]> wrote:

Never mind. I miss last email and see that is beta still.

wt., 12 mar 2019 o 09:41 Piotr Zarzycki <[hidden email]>
napisał(a):

> Hi Guys,
>
> In other words this build 103 wasn't released yet ?
>
> Thanks,
> Piotr
>
> wt., 12 mar 2019 o 00:58 bilbosax <[hidden email]> napisał(a):
>
>> This is the post on Adobe where I asked the same question:
>>
>> https://forums.adobe.com/thread/2597960
>>
>> I was directed to use the AIR 32 Beta that had been updated since AIR 32
>> was
>> added to the Apache installer
>>
>> https://labs.adobe.com/downloads/air.html
>>
>>
>> It worked for me like a charm.  No issues so far.
>>
>>
>>
>> --
>> Sent from: http://apache-flex-users.2333346.n4.nabble.com/
>>
>
>
> --
>
> Piotr Zarzycki
>
> Patreon: *https://www.patreon.com/piotrzarzycki
> <https://www.patreon.com/piotrzarzycki>*
>


--

Piotr Zarzycki

Patreon: *https://www.patreon.com/piotrzarzycki
<https://www.patreon.com/piotrzarzycki>*

Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Olaf Krueger
> Is there some second step needed when overlaying a new AIR SDK over
existing Flex/AIR SDK directory?

Just a shoot in the dark:
Did you check if the config files in /frameworks contain the right player
and swf version?:
air-config.xml
airmobile-config.xml
flex-config.xml

Olaf




--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Alex Harui-2
In reply to this post by Erik Thomas
Does build 103 have both Flex (no compiler) and regular versions (with compiler).  You might have better luck with the one without the packaged compiler.

In theory, there is also a way to override where the installer pulls the builds.  You can create a local.properties file in the new folder the installer is given and add properties that override what the installer is using.

HTH,
-Alex

On 3/12/19, 9:43 AM, "Erik Thomas" <[hidden email]> wrote:

    Sorry to ask an old question again, but I copied the 103 build over my current FlexSDK directory created with the Flex SDK installer last week and it has hosed my builds:
   
    Error:[EventCommons]: java.lang.NoClassDefFoundError: flex2/tools/VersionInfo
    at com.intellij.flex.compiler.FlexCompiler.<clinit>(FlexCompiler.java:19)
    Caused by: java.lang.ClassNotFoundException: flex2.tools.VersionInfo
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    ... 1 more
   
    Is there some second step needed when overlaying a new AIR SDK over existing Flex/AIR SDK directory?
   
    Thanks.
   
    On Mar 12, 2019, at 1:43 AM, Piotr Zarzycki <[hidden email]> wrote:
   
    Never mind. I miss last email and see that is beta still.
   
    wt., 12 mar 2019 o 09:41 Piotr Zarzycki <[hidden email]>
    napisał(a):
   
    > Hi Guys,
    >
    > In other words this build 103 wasn't released yet ?
    >
    > Thanks,
    > Piotr
    >
    > wt., 12 mar 2019 o 00:58 bilbosax <[hidden email]> napisał(a):
    >
    >> This is the post on Adobe where I asked the same question:
    >>
    >> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fforums.adobe.com%2Fthread%2F2597960&amp;data=02%7C01%7Caharui%40adobe.com%7C3b8533f6f9d94b35e5a508d6a709dbe4%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636880058113346717&amp;sdata=qP0oTl0PHXLI7Nk7pTuaJeX1HwKmi86rsQxSzNCD56w%3D&amp;reserved=0
    >>
    >> I was directed to use the AIR 32 Beta that had been updated since AIR 32
    >> was
    >> added to the Apache installer
    >>
    >> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Flabs.adobe.com%2Fdownloads%2Fair.html&amp;data=02%7C01%7Caharui%40adobe.com%7C3b8533f6f9d94b35e5a508d6a709dbe4%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636880058113346717&amp;sdata=0NAF7c1hiMEsWWh3KpJnQSD0O8cCm52DhnYjI%2Fnvf3k%3D&amp;reserved=0
    >>
    >>
    >> It worked for me like a charm.  No issues so far.
    >>
    >>
    >>
    >> --
    >> Sent from: https://nam04.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-flex-users.2333346.n4.nabble.com%2F&amp;data=02%7C01%7Caharui%40adobe.com%7C3b8533f6f9d94b35e5a508d6a709dbe4%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636880058113346717&amp;sdata=qA0Jx%2FkZaHTkT2ZNeaDjYhECJeft9UzpCm%2FOjXe98dY%3D&amp;reserved=0
    >>
    >
    >
    > --
    >
    > Piotr Zarzycki
    >
    > Patreon: *https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.patreon.com%2Fpiotrzarzycki&amp;data=02%7C01%7Caharui%40adobe.com%7C3b8533f6f9d94b35e5a508d6a709dbe4%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636880058113346717&amp;sdata=uNX4TtAV%2B0BCkFDX0lKFUtr5SgpcOz5mih9T5z%2FfubQ%3D&amp;reserved=0
    > <https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.patreon.com%2Fpiotrzarzycki&amp;data=02%7C01%7Caharui%40adobe.com%7C3b8533f6f9d94b35e5a508d6a709dbe4%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636880058113346717&amp;sdata=uNX4TtAV%2B0BCkFDX0lKFUtr5SgpcOz5mih9T5z%2FfubQ%3D&amp;reserved=0>*
    >
   
   
    --
   
    Piotr Zarzycki
   
    Patreon: *https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.patreon.com%2Fpiotrzarzycki&amp;data=02%7C01%7Caharui%40adobe.com%7C3b8533f6f9d94b35e5a508d6a709dbe4%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636880058113346717&amp;sdata=uNX4TtAV%2B0BCkFDX0lKFUtr5SgpcOz5mih9T5z%2FfubQ%3D&amp;reserved=0
    <https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.patreon.com%2Fpiotrzarzycki&amp;data=02%7C01%7Caharui%40adobe.com%7C3b8533f6f9d94b35e5a508d6a709dbe4%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636880058113346717&amp;sdata=uNX4TtAV%2B0BCkFDX0lKFUtr5SgpcOz5mih9T5z%2FfubQ%3D&amp;reserved=0>*
   
   

Reply | Threaded
Open this post in threaded view
|

Re: SDK Version Issue for iOS

Erik Thomas
This link:

https://labs.adobe.com/downloads/air.html <https://labs.adobe.com/downloads/air.html>

Shows only download links for the AIR runtime, or AIR SDK & Compiler, or AIR SDK For Flex Developers. I downloaded the last one, thinking it may not include the compiler.

I guess I'll try again from fresh install of AIR 32 from Flex SDK Installer, and download 103 build with the AIR SDK & Compiler download.

And thanks for the suggestion Olaf, I checked those config files and all are correct.

Erik