Problem with creating new Locale

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with creating new Locale

mark goldin
I am creating a new locale "en_GB". For that I created a new folder "en_GB"
under locale and copy into it all my en_US bundles. I also modified
flex.proj file by adding a new locale there. The build builds new locale
without a problem, but when I run the app. all date are shown in an us
format. What am I missing?

Thanks
Reply | Threaded
Open this post in threaded view
|

RE: Problem with creating new Locale

Idylog - Nicolas Granon
I remind that creating a new locale implies using the "copylocale" utility.
The date formats must reside inside "formatters.properties" (maybe you should also check validators.propertie for date validation).
I believe that you first copy the "source" locale to some intermediate pseudo-locale.
There you update the properties files.
Then you use copylocale again from the intermediate to the real target locale.

Hope this helps

Nicolas Granon




> -----Message d'origine-----
> De : mark goldin [mailto:[hidden email]]
> Envoyé : lundi 6 novembre 2017 18:58
> À : [hidden email]
> Objet : Problem with creating new Locale
>
> I am creating a new locale "en_GB". For that I created a new folder
> "en_GB"
> under locale and copy into it all my en_US bundles. I also modified
> flex.proj file by adding a new locale there. The build builds new
> locale without a problem, but when I run the app. all date are shown in
> an us format. What am I missing?
>
> Thanks

Reply | Threaded
Open this post in threaded view
|

Re: Problem with creating new Locale

mark goldin
Can you please elaborate on that?

On Mon, Nov 6, 2017 at 12:17 PM Idylog - Nicolas Granon <[hidden email]>
wrote:

> I remind that creating a new locale implies using the "copylocale" utility.
> The date formats must reside inside "formatters.properties" (maybe you
> should also check validators.propertie for date validation).
> I believe that you first copy the "source" locale to some intermediate
> pseudo-locale.
> There you update the properties files.
> Then you use copylocale again from the intermediate to the real target
> locale.
>
> Hope this helps
>
> Nicolas Granon
>
>
>
>
> > -----Message d'origine-----
> > De : mark goldin [mailto:[hidden email]]
> > Envoyé : lundi 6 novembre 2017 18:58
> > À : [hidden email]
> > Objet : Problem with creating new Locale
> >
> > I am creating a new locale "en_GB". For that I created a new folder
> > "en_GB"
> > under locale and copy into it all my en_US bundles. I also modified
> > flex.proj file by adding a new locale there. The build builds new
> > locale without a problem, but when I run the app. all date are shown in
> > an us format. What am I missing?
> >
> > Thanks
>
>
Reply | Threaded
Open this post in threaded view
|

RE: Problem with creating new Locale

Idylog - Nicolas Granon
Rethinking about it, I'm not sure that date formats are specified in resource files.

Rather, they come from the formatters classes.

Could do describe :
How are date displayed by now ?
How would you like the dates displayed ?

Do you use a formatter for displaying dates ?
(if yes) Is it a mx formatter, a spark formatter or any other custom formatter ?

Nicolas Granon




> -----Message d'origine-----
> De : mark goldin [mailto:[hidden email]]
> Envoyé : lundi 6 novembre 2017 19:18
> À : [hidden email]; [hidden email]
> Objet : Re: Problem with creating new Locale
>
> Can you please elaborate on that?
>
> On Mon, Nov 6, 2017 at 12:17 PM Idylog - Nicolas Granon
> <[hidden email]>
> wrote:
>
> > I remind that creating a new locale implies using the "copylocale"
> utility.
> > The date formats must reside inside "formatters.properties" (maybe
> you
> > should also check validators.propertie for date validation).
> > I believe that you first copy the "source" locale to some
> intermediate
> > pseudo-locale.
> > There you update the properties files.
> > Then you use copylocale again from the intermediate to the real
> target
> > locale.
> >
> > Hope this helps
> >
> > Nicolas Granon
> >
> >
> >
> >
> > > -----Message d'origine-----
> > > De : mark goldin [mailto:[hidden email]] Envoyé : lundi 6
> > > novembre 2017 18:58 À : [hidden email] Objet : Problem with
> > > creating new Locale
> > >
> > > I am creating a new locale "en_GB". For that I created a new folder
> > > "en_GB"
> > > under locale and copy into it all my en_US bundles. I also modified
> > > flex.proj file by adding a new locale there. The build builds new
> > > locale without a problem, but when I run the app. all date are
> shown
> > > in an us format. What am I missing?
> > >
> > > Thanks
> >
> >

Reply | Threaded
Open this post in threaded view
|

Re: Problem with creating new Locale

mark goldin
When I use French the dates are shown correctly. But for GB it is still the
US.

On Mon, Nov 6, 2017 at 3:53 PM Idylog - Nicolas Granon <[hidden email]>
wrote:

> Rethinking about it, I'm not sure that date formats are specified in
> resource files.
>
> Rather, they come from the formatters classes.
>
> Could do describe :
> How are date displayed by now ?
> How would you like the dates displayed ?
>
> Do you use a formatter for displaying dates ?
> (if yes) Is it a mx formatter, a spark formatter or any other custom
> formatter ?
>
> Nicolas Granon
>
>
>
>
> > -----Message d'origine-----
> > De : mark goldin [mailto:[hidden email]]
> > Envoyé : lundi 6 novembre 2017 19:18
> > À : [hidden email]; [hidden email]
> > Objet : Re: Problem with creating new Locale
> >
> > Can you please elaborate on that?
> >
> > On Mon, Nov 6, 2017 at 12:17 PM Idylog - Nicolas Granon
> > <[hidden email]>
> > wrote:
> >
> > > I remind that creating a new locale implies using the "copylocale"
> > utility.
> > > The date formats must reside inside "formatters.properties" (maybe
> > you
> > > should also check validators.propertie for date validation).
> > > I believe that you first copy the "source" locale to some
> > intermediate
> > > pseudo-locale.
> > > There you update the properties files.
> > > Then you use copylocale again from the intermediate to the real
> > target
> > > locale.
> > >
> > > Hope this helps
> > >
> > > Nicolas Granon
> > >
> > >
> > >
> > >
> > > > -----Message d'origine-----
> > > > De : mark goldin [mailto:[hidden email]] Envoyé : lundi 6
> > > > novembre 2017 18:58 À : [hidden email] Objet : Problem with
> > > > creating new Locale
> > > >
> > > > I am creating a new locale "en_GB". For that I created a new folder
> > > > "en_GB"
> > > > under locale and copy into it all my en_US bundles. I also modified
> > > > flex.proj file by adding a new locale there. The build builds new
> > > > locale without a problem, but when I run the app. all date are
> > shown
> > > > in an us format. What am I missing?
> > > >
> > > > Thanks
> > >
> > >
>
>
Reply | Threaded
Open this post in threaded view
|

RE: Problem with creating new Locale

Idylog - Nicolas Granon
How do you format your dates ? (mx formatter ? spark formatter ?)

Nicolas Granon




> -----Message d'origine-----
> De : mark goldin [mailto:[hidden email]]
> Envoyé : lundi 6 novembre 2017 22:56
> À : [hidden email]; [hidden email]
> Objet : Re: Problem with creating new Locale
>
> When I use French the dates are shown correctly. But for GB it is still
> the US.
>
> On Mon, Nov 6, 2017 at 3:53 PM Idylog - Nicolas Granon
> <[hidden email]>
> wrote:
>
> > Rethinking about it, I'm not sure that date formats are specified in
> > resource files.
> >
> > Rather, they come from the formatters classes.
> >
> > Could do describe :
> > How are date displayed by now ?
> > How would you like the dates displayed ?
> >
> > Do you use a formatter for displaying dates ?
> > (if yes) Is it a mx formatter, a spark formatter or any other custom
> > formatter ?
> >
> > Nicolas Granon
> >
> >
> >
> >
> > > -----Message d'origine-----
> > > De : mark goldin [mailto:[hidden email]] Envoyé : lundi 6
> > > novembre 2017 19:18 À : [hidden email]; [hidden email]
> > > Objet : Re: Problem with creating new Locale
> > >
> > > Can you please elaborate on that?
> > >
> > > On Mon, Nov 6, 2017 at 12:17 PM Idylog - Nicolas Granon
> > > <[hidden email]>
> > > wrote:
> > >
> > > > I remind that creating a new locale implies using the
> "copylocale"
> > > utility.
> > > > The date formats must reside inside "formatters.properties"
> (maybe
> > > you
> > > > should also check validators.propertie for date validation).
> > > > I believe that you first copy the "source" locale to some
> > > intermediate
> > > > pseudo-locale.
> > > > There you update the properties files.
> > > > Then you use copylocale again from the intermediate to the real
> > > target
> > > > locale.
> > > >
> > > > Hope this helps
> > > >
> > > > Nicolas Granon
> > > >
> > > >
> > > >
> > > >
> > > > > -----Message d'origine-----
> > > > > De : mark goldin [mailto:[hidden email]] Envoyé : lundi
> 6
> > > > > novembre 2017 18:58 À : [hidden email] Objet : Problem
> > > > > with creating new Locale
> > > > >
> > > > > I am creating a new locale "en_GB". For that I created a new
> > > > > folder "en_GB"
> > > > > under locale and copy into it all my en_US bundles. I also
> > > > > modified flex.proj file by adding a new locale there. The build
> > > > > builds new locale without a problem, but when I run the app.
> all
> > > > > date are
> > > shown
> > > > > in an us format. What am I missing?
> > > > >
> > > > > Thanks
> > > >
> > > >
> >
> >

Reply | Threaded
Open this post in threaded view
|

Re: Problem with creating new Locale

mark goldin
It's mx.

On Mon, Nov 6, 2017 at 4:03 PM Idylog - Nicolas Granon <[hidden email]>
wrote:

> How do you format your dates ? (mx formatter ? spark formatter ?)
>
> Nicolas Granon
>
>
>
>
> > -----Message d'origine-----
> > De : mark goldin [mailto:[hidden email]]
> > Envoyé : lundi 6 novembre 2017 22:56
> > À : [hidden email]; [hidden email]
> > Objet : Re: Problem with creating new Locale
> >
> > When I use French the dates are shown correctly. But for GB it is still
> > the US.
> >
> > On Mon, Nov 6, 2017 at 3:53 PM Idylog - Nicolas Granon
> > <[hidden email]>
> > wrote:
> >
> > > Rethinking about it, I'm not sure that date formats are specified in
> > > resource files.
> > >
> > > Rather, they come from the formatters classes.
> > >
> > > Could do describe :
> > > How are date displayed by now ?
> > > How would you like the dates displayed ?
> > >
> > > Do you use a formatter for displaying dates ?
> > > (if yes) Is it a mx formatter, a spark formatter or any other custom
> > > formatter ?
> > >
> > > Nicolas Granon
> > >
> > >
> > >
> > >
> > > > -----Message d'origine-----
> > > > De : mark goldin [mailto:[hidden email]] Envoyé : lundi 6
> > > > novembre 2017 19:18 À : [hidden email]; [hidden email]
> > > > Objet : Re: Problem with creating new Locale
> > > >
> > > > Can you please elaborate on that?
> > > >
> > > > On Mon, Nov 6, 2017 at 12:17 PM Idylog - Nicolas Granon
> > > > <[hidden email]>
> > > > wrote:
> > > >
> > > > > I remind that creating a new locale implies using the
> > "copylocale"
> > > > utility.
> > > > > The date formats must reside inside "formatters.properties"
> > (maybe
> > > > you
> > > > > should also check validators.propertie for date validation).
> > > > > I believe that you first copy the "source" locale to some
> > > > intermediate
> > > > > pseudo-locale.
> > > > > There you update the properties files.
> > > > > Then you use copylocale again from the intermediate to the real
> > > > target
> > > > > locale.
> > > > >
> > > > > Hope this helps
> > > > >
> > > > > Nicolas Granon
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > > -----Message d'origine-----
> > > > > > De : mark goldin [mailto:[hidden email]] Envoyé : lundi
> > 6
> > > > > > novembre 2017 18:58 À : [hidden email] Objet : Problem
> > > > > > with creating new Locale
> > > > > >
> > > > > > I am creating a new locale "en_GB". For that I created a new
> > > > > > folder "en_GB"
> > > > > > under locale and copy into it all my en_US bundles. I also
> > > > > > modified flex.proj file by adding a new locale there. The build
> > > > > > builds new locale without a problem, but when I run the app.
> > all
> > > > > > date are
> > > > shown
> > > > > > in an us format. What am I missing?
> > > > > >
> > > > > > Thanks
> > > > >
> > > > >
> > >
> > >
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Problem with creating new Locale

jmclean
Administrator
In reply to this post by mark goldin
Hi,

> I am creating a new locale "en_GB". For that I created a new folder "en_GB"
> under locale and copy into it all my en_US bundles.

The Flex SDK supports the en_GB locale since version 4.9 are you using an ealier version?

Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|

RE: Problem with creating new Locale

mark goldin
I am using 4.13.

Sent from my Windows 10 phone

From: Justin Mclean
Sent: Monday, November 6, 2017 4:48 PM
To: [hidden email]
Subject: Re: Problem with creating new Locale

Hi,

> I am creating a new locale "en_GB". For that I created a new folder "en_GB"
> under locale and copy into it all my en_US bundles.

The Flex SDK supports the en_GB locale since version 4.9 are you using an ealier version?

Thanks,
Justin