Outdated AIR version in Apache SDK Installer

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Outdated AIR version in Apache SDK Installer

Octavio Molano Anta
Hello all.

I've noticed that the Apache Flex installer only has the option to install
up to AIR 24 Beta.

The Final version of AIR 24 was released back in December. The installer
should have been updated by now.

Also it would be nice to have the installer also updated for the current
AIR 25 Beta (25.0.0.108).

Finally, if the installer is not going to be updated frequently, it would
probably be a good idea to let the user manually specify an updated
download URL in the installer interface to make the process easier.

Best regards,
Octavio
Reply | Threaded
Open this post in threaded view
|

Re: Outdated AIR version in Apache SDK Installer

clintm
I think there was a change on the Adobe side in the way that they package
the sdk now that's not compatible with the current version of the installer
(dmg vs archive).

As a workaround you can copy any AIR SDK over top of any Apache Flex SDK
and it'll work.

Here's a tutorial:
https://helpx.adobe.com/x-productkb/multi/how-overlay-air-sdk-flex-sdk.html



On Thu, Feb 9, 2017 at 6:00 AM, Octavio Molano Anta <
[hidden email]> wrote:

> Hello all.
>
> I've noticed that the Apache Flex installer only has the option to install
> up to AIR 24 Beta.
>
> The Final version of AIR 24 was released back in December. The installer
> should have been updated by now.
>
> Also it would be nice to have the installer also updated for the current
> AIR 25 Beta (25.0.0.108).
>
> Finally, if the installer is not going to be updated frequently, it would
> probably be a good idea to let the user manually specify an updated
> download URL in the installer interface to make the process easier.
>
> Best regards,
> Octavio
>
Reply | Threaded
Open this post in threaded view
|

Re: Outdated AIR version in Apache SDK Installer

Octavio Molano Anta
Thank you. So basically copying the latest AIR SDK files into the same
folder as the latest Apache Flex SDK overwriting existing files would be
enough, wouldn't it? (apart from changing the xmlns attribute in the app
descriptor).

Anyway, are there any plans to update the Apache Flex installer to support
the newer AIR .dmg packages?

Best regards,
Octavio


2017-02-09 17:22 GMT+01:00 Clint M <[hidden email]>:

> I think there was a change on the Adobe side in the way that they package
> the sdk now that's not compatible with the current version of the installer
> (dmg vs archive).
>
> As a workaround you can copy any AIR SDK over top of any Apache Flex SDK
> and it'll work.
>
> Here's a tutorial:
> https://helpx.adobe.com/x-productkb/multi/how-overlay-
> air-sdk-flex-sdk.html
>
>
>
> On Thu, Feb 9, 2017 at 6:00 AM, Octavio Molano Anta <
> [hidden email]> wrote:
>
> > Hello all.
> >
> > I've noticed that the Apache Flex installer only has the option to
> install
> > up to AIR 24 Beta.
> >
> > The Final version of AIR 24 was released back in December. The installer
> > should have been updated by now.
> >
> > Also it would be nice to have the installer also updated for the current
> > AIR 25 Beta (25.0.0.108).
> >
> > Finally, if the installer is not going to be updated frequently, it would
> > probably be a good idea to let the user manually specify an updated
> > download URL in the installer interface to make the process easier.
> >
> > Best regards,
> > Octavio
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: Outdated AIR version in Apache SDK Installer

Josh Tynjala
The upcoming Apache Flex 4.16 will support the DMG packages in it's install
script.

- Josh

On Fri, Feb 10, 2017 at 9:22 AM, Octavio Molano Anta <
[hidden email]> wrote:

> Thank you. So basically copying the latest AIR SDK files into the same
> folder as the latest Apache Flex SDK overwriting existing files would be
> enough, wouldn't it? (apart from changing the xmlns attribute in the app
> descriptor).
>
> Anyway, are there any plans to update the Apache Flex installer to support
> the newer AIR .dmg packages?
>
> Best regards,
> Octavio
>
>
> 2017-02-09 17:22 GMT+01:00 Clint M <[hidden email]>:
>
> > I think there was a change on the Adobe side in the way that they package
> > the sdk now that's not compatible with the current version of the
> installer
> > (dmg vs archive).
> >
> > As a workaround you can copy any AIR SDK over top of any Apache Flex SDK
> > and it'll work.
> >
> > Here's a tutorial:
> > https://helpx.adobe.com/x-productkb/multi/how-overlay-
> > air-sdk-flex-sdk.html
> >
> >
> >
> > On Thu, Feb 9, 2017 at 6:00 AM, Octavio Molano Anta <
> > [hidden email]> wrote:
> >
> > > Hello all.
> > >
> > > I've noticed that the Apache Flex installer only has the option to
> > install
> > > up to AIR 24 Beta.
> > >
> > > The Final version of AIR 24 was released back in December. The
> installer
> > > should have been updated by now.
> > >
> > > Also it would be nice to have the installer also updated for the
> current
> > > AIR 25 Beta (25.0.0.108).
> > >
> > > Finally, if the installer is not going to be updated frequently, it
> would
> > > probably be a good idea to let the user manually specify an updated
> > > download URL in the installer interface to make the process easier.
> > >
> > > Best regards,
> > > Octavio
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: Outdated AIR version in Apache SDK Installer

Filip Hoeven
When does Apache Flex 4.16 and the fixed installer be released?
Reply | Threaded
Open this post in threaded view
|

Re: Outdated AIR version in Apache SDK Installer

jmclean
Administrator
HI,

> When does Apache Flex 4.16 and the fixed installer be released?

When I can find the time to create the latest RC (and review / test which takes several hours) and then put it up for vote. Sorry I’ve been busy with other work recently and haven’t been able to find enough hours in the day to do everything.

So hopefully that means sometime this week and if all is good then would be released early next week.

Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|

Re: Outdated AIR version in Apache SDK Installer

Filip Hoeven
Hi,

I understand you're effort is voluntary and you need to find the time.
Hope you find some time. Thanks in advance.

Would be good to see some movement/change on the Apache Flex website, I wasn't aware it was still alive until I found this user group.

Kind regards,
Filip


Op wo 1 mrt. 2017 om 01:47 schreef jmclean [via Apache Flex Users] <[hidden email]>:
HI,

> When does Apache Flex 4.16 and the fixed installer be released?

When I can find the time to create the latest RC (and review / test which takes several hours) and then put it up for vote. Sorry I’ve been busy with other work recently and haven’t been able to find enough hours in the day to do everything.

So hopefully that means sometime this week and if all is good then would be released early next week.

Thanks,
Justin


If you reply to this email, your message will be added to the discussion below:
http://apache-flex-users.2333346.n4.nabble.com/Outdated-AIR-version-in-Apache-SDK-Installer-tp14665p14742.html
To unsubscribe from Outdated AIR version in Apache SDK Installer, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Outdated AIR version in Apache SDK Installer

Artemide Aste
Hello,

I totally agree that the website should be updated with some recent news.
It will keep the spirit up of Flex developers not subscribed to this user
group. How to help?

Lorenzo

2017-03-01 23:02 GMT+01:00 Filip Hoeven <[hidden email]>:

> Hi,
>
> I understand you're effort is voluntary and you need to find the time.
> Hope you find some time. Thanks in advance.
>
> Would be good to see some movement/change on the Apache Flex website, I
> wasn't aware it was still alive until I found this user group.
>
> Kind regards,
> Filip
>
>
> Op wo 1 mrt. 2017 om 01:47 schreef jmclean [via Apache Flex Users] <
> [hidden email]>:
>
> > HI,
> >
> > > When does Apache Flex 4.16 and the fixed installer be released?
> >
> > When I can find the time to create the latest RC (and review / test which
> > takes several hours) and then put it up for vote. Sorry I’ve been busy
> with
> > other work recently and haven’t been able to find enough hours in the day
> > to do everything.
> >
> > So hopefully that means sometime this week and if all is good then would
> > be released early next week.
> >
> > Thanks,
> > Justin
> >
> > ------------------------------
> > If you reply to this email, your message will be added to the discussion
> > below:
> >
> > http://apache-flex-users.2333346.n4.nabble.com/Outdated-AIR-version-in-
> Apache-SDK-Installer-tp14665p14742.html
> > To unsubscribe from Outdated AIR version in Apache SDK Installer, click
> > here
> > <http://apache-flex-users.2333346.n4.nabble.com/
> template/NamlServlet.jtp?macro=unsubscribe_by_code&node=14665&code=
> ZmlsaXAuaG9ldmVuQGdtYWlsLmNvbXwxNDY2NXwtNjU5ODI2MjYw>
> > .
> > NAML
> > <http://apache-flex-users.2333346.n4.nabble.com/
> template/NamlServlet.jtp?macro=macro_viewer&id=instant_
> html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.
> BasicNamespace-nabble.view.web.template.NabbleNamespace-
> nabble.view.web.template.NodeNamespace&breadcrumbs=
> notify_subscribers%21nabble%3Aemail.naml-instant_emails%
> 21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
> >
>
>
>
>
> --
> View this message in context: http://apache-flex-users.
> 2333346.n4.nabble.com/Outdated-AIR-version-in-Apache-SDK-Installer-
> tp14665p14749.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>



--
Artemide Aste s.r.l.
Via Consiglio dei Sessanta, 99 - 47891 Dogana - Repubblica di San Marino
T: 0549 908845 - int.l +378 0549 908845
F: 0549 972142 - int.l +378 0549 972142
Email: [hidden email]
https://www.artemideaste.com <http://www.artemideaste.com>
https://www.deamoneta.com/artemideaste/
<http://www.deamoneta.com/artemideaste/>

Artemide Aste App for iOS:
https://itunes.apple.com/us/app/artemide-aste/id1081984520?mt=8
DeaMoneta App for Android:
https://play.google.com/store/apps/details?id=com.artemideaste.mobile
Reply | Threaded
Open this post in threaded view
|

Re: Outdated AIR version in Apache SDK Installer

Alex Harui


On 3/2/17, 1:20 AM, "Artemide Aste" <[hidden email]> wrote:

>Hello,
>
>I totally agree that the website should be updated with some recent news.
>It will keep the spirit up of Flex developers not subscribed to this user
>group. How to help?

Just about everything at Apache is open source, even our web site.

The source is in a Subversion repo at [1].  Some instructions for updating
are at [2]

[1] http://svn.apache.org/viewvc/flex/site/trunk/
[2] https://cwiki.apache.org/confluence/display/FLEX/Website+Information

Patches are most welcome.  Other ideas are welcome too.

Thanks,
-Alex

Reply | Threaded
Open this post in threaded view
|

Re: Outdated AIR version in Apache SDK Installer

LesGWoolsey
In reply to this post by clintm
I followed the instructions indicated and copied the files for air beta 25 with compiler over another seek.  When I try to add it to FB 4.7 it says the directory does not contain a Flex SDK.  Any ideas on what's wrong.  

Of course if the apache flex installer would handle Air 25, I wouldn't need to try to kludge it.

Thanks
Les
Reply | Threaded
Open this post in threaded view
|

Re: Outdated AIR version in Apache SDK Installer

clintm
This happens to me if I use the mac finder to copy the air sdk in to the
flex sdk. It works if I use the command line utility cp.

On Wed, Mar 8, 2017 at 7:45 PM, LesGWoolsey <[hidden email]> wrote:

> I followed the instructions indicated and copied the files for air beta 25
> with compiler over another seek.  When I try to add it to FB 4.7 it says
> the
> directory does not contain a Flex SDK.  Any ideas on what's wrong.
>
> Of course if the apache flex installer would handle Air 25, I wouldn't need
> to try to kludge it.
>
> Thanks
> Les
>
>
>
> --
> View this message in context: http://apache-flex-users.
> 2333346.n4.nabble.com/Outdated-AIR-version-in-Apache-SDK-Installer-
> tp14665p14793.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Outdated AIR version in Apache SDK Installer

LesGWoolsey
OK. That worked!  It now thinks the SDK is there.  Now to see if it fixes the problem...

Thanks