Flexmojos Maven Apache Flex Error 1014

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Flexmojos Maven Apache Flex Error 1014

rodolpho@essencialcode.com.br
Hello everyone,

I really need your help; I am trying to compile an extense flex project(4.15) using Maven and FlexMojos (7.1.0), just solved many problems until here, finally got success in last compilation process, but when I execute it using the generated html page there is one problem I'm trying to solve unsuccessfully;

VerifyError: Error #1014: Class spark.components::Application could not be found.

I just tried in many ways to put the dependencies in swf pom, modified the order, made many changes but the error still there, visited many pages and examples, just tried almost everything and nothing;

Somebody can help me ? thanks in advance; Here is my final swf pom.xml :

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
  <modelVersion>4.0.0</modelVersion>
 
   <parent>
  </parent>

  <artifactId>....</artifactId>
  <packaging>swf</packaging>
  <name>...</name>
 
  <build>
     <sourceDirectory>src</sourceDirectory>
         
         <resources>
       <resource>
          <directory>src/br/....</directory>
       </resource>
       <resource>
          <directory>src/br/com/...</directory>
       </resource>
     </resources>
         
     <plugins>
   
                        <plugin>
                <groupId>net.flexmojos.oss</groupId>
                <artifactId>flexmojos-maven-plugin</artifactId>
                <version>${flexmojos.version}</version>
                <extensions>true</extensions>
                               
                                <executions>
                                        <execution>
                                            <id>create-rsl</id>
                                                <goals>
                                                        <goal>create-rsl</goal>
                                                </goals>
                                        </execution>
                               
                                        <execution>
                                            <id>wrapper</id>
                                                <goals>
     <goal>wrapper</goal>
                                                </goals>
                                               
                                                <configuration>
                            <parameters>
                                <swf>.....</swf>
                                <width>100%</width>
                                <height>100%</height>
                                <version_major>${flash.framework.version}</version_major>
                                <version_minor>${flash.framework.version}</version_minor>
                                <bgcolor>#FFFFFF</bgcolor>
                            </parameters>
                            <htmlName>....</htmlName>
                                                       
                                                </configuration>
                                        </execution>                               

                                </executions>
                               
                                <configuration>
                                        <rslUrls>
                                                <rsl>{artifactId}-${flex.sdk.version}.{extension}</rsl>
                                        </rslUrls>
                               
                   <removeUnusedRsls>true</removeUnusedRsls>               
                                        <accessible>true</accessible>
                                        <includes>
                                                <symbol>mx.managers.systemClasses.MarshallingSupport</symbol>
                                        </includes>

                                        <runtimeLocales>
                                                <locale>en_US</locale>
                                        </runtimeLocales>                               
                                       
                                        <sourceFile> ....... </sourceFile>                                       

    <modules>
                                                <module>
                                                </module>
                                               
                                                <module>
                                                </module>
                                               
                                                <module>
                                                </module>
       
                                                <module>
                                                </module>
                                        </modules>

                                   <finalName>....</finalName>
                                   
                </configuration>
                        </plugin>
                </plugins>         
 
  </build>
 
   <dependencies>

   
        <dependency>
            <groupId>org.apache.flex.framework</groupId>
            <artifactId>framework</artifactId>
                        <version>${flex.sdk.version}</version>
                        <type>swc</type>
                        <scope>rsl</scope>
        </dependency>

        <dependency>
            <groupId>org.apache.flex.framework</groupId>
            <artifactId>textLayout</artifactId>
                        <version>${flex.sdk.version}</version>
                        <type>swc</type>
                        <scope>rsl</scope>
        </dependency>

        <dependency>
            <groupId>org.apache.flex.framework</groupId>
            <artifactId>spark</artifactId>
                        <version>${flex.sdk.version}</version>
                        <type>swc</type>
                        <scope>rsl</scope>
        </dependency>

        <dependency>
            <groupId>org.apache.flex.framework</groupId>
            <artifactId>sparkskins</artifactId>
                        <version>${flex.sdk.version}</version>
                        <type>swc</type>
                        <scope>rsl</scope>
        </dependency>

        <dependency>
            <groupId>org.apache.flex.framework</groupId>
            <artifactId>rpc</artifactId>
                        <version>${flex.sdk.version}</version>
                        <type>swc</type>
                        <scope>rsl</scope>
        </dependency>
               
                <dependency> 
            <groupId>org.apache.flex.framework</groupId> 
            <artifactId>charts</artifactId> 
            <version>${flex.sdk.version}</version> 
            <type>swc</type> 
            <scope>rsl</scope> 
        </dependency> 
               
        <dependency> 
            <groupId>org.apache.flex.framework</groupId> 
            <artifactId>spark_dmv</artifactId> 
            <version>${flex.sdk.version}</version> 
            <type>swc</type> 
            <scope>rsl</scope> 
        </dependency> 

        <dependency>
            <groupId>org.apache.flex.framework</groupId>
            <artifactId>mx</artifactId>
                        <version>${flex.sdk.version}</version>
                        <type>swc</type>
                        <scope>rsl</scope>
        </dependency>
               
                <dependency> 
            <groupId>org.apache.flex.framework</groupId> 
            <artifactId>advancedgrids</artifactId> 
            <version>${flex.sdk.version}</version> 
            <type>swc</type> 
            <scope>rsl</scope> 
        </dependency> 
               
                <dependency> 
            <groupId>org.apache.flex.framework</groupId> 
            <artifactId>apache</artifactId> 
            <version>${flex.sdk.version}</version> 
            <type>swc</type> 
            <scope>rsl</scope> 
        </dependency> 

                <dependency> 
            <groupId>org.apache.flex.framework</groupId> 
            <artifactId>authoringsupport</artifactId> 
            <version>${flex.sdk.version}</version> 
            <type>swc</type> 
            <scope>rsl</scope> 
        </dependency> 
               
        <dependency> 
            <groupId>org.apache.flex.framework</groupId> 
            <artifactId>core</artifactId> 
            <version>${flex.sdk.version}</version> 
            <type>swc</type> 
            <scope>rsl</scope> 
        </dependency> 
               
        <dependency> 
            <groupId>org.apache.flex.framework</groupId> 
            <artifactId>experimental</artifactId> 
            <version>${flex.sdk.version}</version> 
            <type>swc</type> 
            <scope>rsl</scope> 
        </dependency> 

        <dependency> 
            <groupId>org.apache.flex.framework</groupId> 
            <artifactId>flatspark</artifactId> 
            <version>${flex.sdk.version}</version> 
            <type>swc</type> 
            <scope>rsl</scope> 
        </dependency> 
               
               
               
        <dependency>
            <groupId>org.apache.flex.framework</groupId>
            <artifactId>framework</artifactId>
                        <version>${flex.sdk.version}</version>
                        <type>rb.swc</type>
                        <scope>internal</scope>
                        <classifier>en_US</classifier>
        </dependency>

        <dependency>
            <groupId>org.apache.flex.framework</groupId>
            <artifactId>textLayout</artifactId>
                        <version>${flex.sdk.version}</version>
                        <type>rb.swc</type>
                        <scope>rsl</scope>
            <classifier>en_US</classifier>
        </dependency>

        <dependency>
            <groupId>org.apache.flex.framework</groupId>
            <artifactId>spark</artifactId>
                        <version>${flex.sdk.version}</version>
                        <type>rb.swc</type>
                        <scope>rsl</scope>
            <classifier>en_US</classifier>
        </dependency>
               
                <dependency>
                        <groupId>org.apache.flex.framework</groupId> 
            <artifactId>rpc</artifactId> 
            <version>${flex.sdk.version}</version> 
            <type>rb.swc</type> 
            <scope>rsl</scope> 
            <classifier>en_US</classifier> 
                </dependency>
                       
                <dependency> 
                        <groupId>org.apache.flex.framework</groupId> 
                        <artifactId>charts</artifactId> 
                        <version>${flex.sdk.version}</version> 
                        <type>rb.swc</type> 
                        <scope>rsl</scope> 
                        <classifier>en_US</classifier> 
                </dependency> 
               
        <dependency>
            <groupId>org.apache.flex.framework</groupId>
            <artifactId>mx</artifactId>
                        <version>${flex.sdk.version}</version>
                        <type>rb.swc</type>
                        <scope>rsl</scope>
            <classifier>en_US</classifier>
        </dependency>

                <dependency> 
            <groupId>org.apache.flex.framework</groupId> 
            <artifactId>advancedgrids</artifactId> 
            <version>${flex.sdk.version}</version> 
            <type>rb.swc</type> 
            <scope>rsl</scope> 
            <classifier>en_US</classifier> 
        </dependency> 
               
        <dependency>
            <groupId>org.apache.flex.framework</groupId>
            <artifactId>apache</artifactId>
                        <version>${flex.sdk.version}</version>
                        <type>rb.swc</type>
                        <scope>rsl</scope>
            <classifier>en_US</classifier>
        </dependency>
               
                <dependency> 
              <optional>true</optional> 
              <groupId>org.apache.flex.framework.themes</groupId> 
              <artifactId>spark</artifactId> 
              <version>${flex.sdk.version}</version> 
              <type>swc</type> 
              <scope>theme</scope> 
        </dependency> 
               
               
        </dependencies> 
         
 
</project>




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Flexmojos Maven Apache Flex Error 1014

Christofer Dutz
Hi Rodolpho,

I think the problem might be that you have “create-rsl” in an SWF project, I would simply remove that execution.
Another thing is that unfortunately things have changed in Maven and now one bug we have been relying on heavily has been “fixed”.
The thing is that using non-standard scopes (such as rsl) the transitive resolution no longer works. This means you have to explicitly
Add rsl scoped dependencies to all swcs that you need.

I did see that you added spark as a direct dependency, so I don’t think it’s that problem. Just try removing the “create-rsl” execution for a start.

Chris


Am 06.04.17, 19:46 schrieb "[hidden email]" <[hidden email]>:

    Hello everyone,
   
    I really need your help; I am trying to compile an extense flex
    project(4.15) using Maven and FlexMojos (7.1.0), just solved many problems
    until here, finally got success in last compilation process, but when I
    execute it using the generated html page there is one problem I'm trying to
    solve unsuccessfully;
   
    VerifyError: Error #1014: Class spark.components::Application could not be
    found.
   
    I just tried in many ways to put the dependencies in swf pom, modified the
    order, made many changes but the error still there, visited many pages and
    examples, just tried almost everything and nothing;
   
    Somebody can help me ? thanks in advance; Here is my final swf pom.xml :
   
    <?xml version="1.0" encoding="UTF-8"?>
    <project xmlns="http://maven.apache.org/POM/4.0.0"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
    http://maven.apache.org/maven-v4_0_0.xsd">
      <modelVersion>4.0.0</modelVersion>
     
       <parent>
      </parent>
   
      <artifactId>....</artifactId>
      <packaging>swf</packaging>
      <name>...</name>
     
      <build>
         <sourceDirectory>src</sourceDirectory>
   
    <resources>
           <resource>
              <directory>src/br/....</directory>
           </resource>
           <resource>
              <directory>src/br/com/...</directory>
           </resource>
         </resources>
   
         <plugins>
       
    <plugin>
                    <groupId>net.flexmojos.oss</groupId>
                    <artifactId>flexmojos-maven-plugin</artifactId>
                    <version>${flexmojos.version}</version>
                    <extensions>true</extensions>
   
    <executions>
    <execution>
       <id>create-rsl</id>
    <goals>
    <goal>create-rsl</goal>
    </goals>
    </execution>
   
    <execution>
       <id>wrapper</id>
    <goals>
         <goal>wrapper</goal>
    </goals>
   
    <configuration>
                                <parameters>
                                    <swf>.....</swf>
                                    <width>100%</width>
                                    <height>100%</height>
                                   
    <version_major>${flash.framework.version}</version_major>
                                   
    <version_minor>${flash.framework.version}</version_minor>
                                    <bgcolor>#FFFFFF</bgcolor>
                                </parameters>
                                <htmlName>....</htmlName>
   
    </configuration>
    </execution>
   
    </executions>
   
    <configuration>
    <rslUrls>
    <rsl>{artifactId}-${flex.sdk.version}.{extension}</rsl>
    </rslUrls>
   
                       <removeUnusedRsls>true</removeUnusedRsls>
    <accessible>true</accessible>
    <includes>
    <symbol>mx.managers.systemClasses.MarshallingSupport</symbol>
    </includes>
   
    <runtimeLocales>
    <locale>en_US</locale>
    </runtimeLocales>
   
    <sourceFile> ....... </sourceFile>
   
        <modules>
    <module>
    </module>
   
    <module>
    </module>
   
    <module>
    </module>
   
    <module>
    </module>
    </modules>
   
      <finalName>....</finalName>
     
                    </configuration>
    </plugin>
    </plugins>
     
      </build>
     
       <dependencies>
   
       
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>framework</artifactId>
    <version>${flex.sdk.version}</version>
    <type>swc</type>
    <scope>rsl</scope>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>textLayout</artifactId>
    <version>${flex.sdk.version}</version>
    <type>swc</type>
    <scope>rsl</scope>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>spark</artifactId>
    <version>${flex.sdk.version}</version>
    <type>swc</type>
    <scope>rsl</scope>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>sparkskins</artifactId>
    <version>${flex.sdk.version}</version>
    <type>swc</type>
    <scope>rsl</scope>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>rpc</artifactId>
    <version>${flex.sdk.version}</version>
    <type>swc</type>
    <scope>rsl</scope>
            </dependency>
   
    <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>charts</artifactId>
                <version>${flex.sdk.version}</version>
                <type>swc</type>
                <scope>rsl</scope>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>spark_dmv</artifactId>
                <version>${flex.sdk.version}</version>
                <type>swc</type>
                <scope>rsl</scope>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>mx</artifactId>
    <version>${flex.sdk.version}</version>
    <type>swc</type>
    <scope>rsl</scope>
            </dependency>
   
    <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>advancedgrids</artifactId>
                <version>${flex.sdk.version}</version>
                <type>swc</type>
                <scope>rsl</scope>
            </dependency>
   
    <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>apache</artifactId>
                <version>${flex.sdk.version}</version>
                <type>swc</type>
                <scope>rsl</scope>
            </dependency>
   
    <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>authoringsupport</artifactId>
                <version>${flex.sdk.version}</version>
                <type>swc</type>
                <scope>rsl</scope>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>core</artifactId>
                <version>${flex.sdk.version}</version>
                <type>swc</type>
                <scope>rsl</scope>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>experimental</artifactId>
                <version>${flex.sdk.version}</version>
                <type>swc</type>
                <scope>rsl</scope>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>flatspark</artifactId>
                <version>${flex.sdk.version}</version>
                <type>swc</type>
                <scope>rsl</scope>
            </dependency>
   
   
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>framework</artifactId>
    <version>${flex.sdk.version}</version>
    <type>rb.swc</type>
    <scope>internal</scope>
    <classifier>en_US</classifier>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>textLayout</artifactId>
    <version>${flex.sdk.version}</version>
    <type>rb.swc</type>
    <scope>rsl</scope>
                <classifier>en_US</classifier>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>spark</artifactId>
    <version>${flex.sdk.version}</version>
    <type>rb.swc</type>
    <scope>rsl</scope>
                <classifier>en_US</classifier>
            </dependency>
   
    <dependency>
    <groupId>org.apache.flex.framework</groupId>
                <artifactId>rpc</artifactId>
                <version>${flex.sdk.version}</version>
                <type>rb.swc</type>
                <scope>rsl</scope>
                <classifier>en_US</classifier>
    </dependency>
   
    <dependency>
    <groupId>org.apache.flex.framework</groupId>
    <artifactId>charts</artifactId>
    <version>${flex.sdk.version}</version>
    <type>rb.swc</type>
    <scope>rsl</scope>
    <classifier>en_US</classifier>
    </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>mx</artifactId>
    <version>${flex.sdk.version}</version>
    <type>rb.swc</type>
    <scope>rsl</scope>
                <classifier>en_US</classifier>
            </dependency>
   
    <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>advancedgrids</artifactId>
                <version>${flex.sdk.version}</version>
                <type>rb.swc</type>
                <scope>rsl</scope>
                <classifier>en_US</classifier>
            </dependency>
   
            <dependency>
                <groupId>org.apache.flex.framework</groupId>
                <artifactId>apache</artifactId>
    <version>${flex.sdk.version}</version>
    <type>rb.swc</type>
    <scope>rsl</scope>
                <classifier>en_US</classifier>
            </dependency>
   
    <dependency>
                  <optional>true</optional>
                  <groupId>org.apache.flex.framework.themes</groupId>
                  <artifactId>spark</artifactId>
                  <version>${flex.sdk.version}</version>
                  <type>swc</type>
                  <scope>theme</scope>
            </dependency>
   
   
    </dependencies>
     
     
    </project>
   
   
   
   
   
   
   
   
    --
    View this message in context: http://apache-flex-users.2333346.n4.nabble.com/Flexmojos-Maven-Apache-Flex-Error-1014-tp14976.html
    Sent from the Apache Flex Users mailing list archive at Nabble.com.
   

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Flexmojos Maven Apache Flex Error 1014

rodolpho@essencialcode.com.br
This post was updated on .
Chris, very thanks for your help;

I just did exactly this and many other forms, but it still showing me the same error, unfortunetly...

Man I'm really pissed with this, I'm trying to fix this for many days, read uncountable web pages with possible solutions, just tried almos anything...

My project has 1 parent pom and 3 modules, 2 swcs and 1 swf, that holds the entire project; I really don't see what is wrong in it; even the adobe framework does not respect the configuration copying libraries, I specified <rsl>{artifactId}-{version}.{extension}</rsl> in first pom and it copies only the <rsl>{artifactId}.{extension}</rsl>;

I really wanted to work this out, I'm trying hard almost two weeks and nothing; It really appers it doesn't find generated framework swf files and they are there, in same target folder;

Chris, you pointed Spark; the error message is

VerifyError: Error #1014: Class spark.components.supportClasses::SkinnableComponent could not be found.

is it correct to reference it as a dependency or not ?










Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: Flexmojos Maven Apache Flex Error 1014

Christofer Dutz
I would try without rsl first and as soon things are working switch.

Chris



Von meinem Samsung Galaxy Smartphone gesendet.


-------- Ursprüngliche Nachricht --------
Von: [hidden email]
Datum: 07.04.17 18:33 (GMT+01:00)
An: [hidden email]
Betreff: Re: Flexmojos Maven Apache Flex Error 1014

Chris, very thanks for your help;

I just did exactly this and many other forms, but it still showing me the
same error, unfortunetly...

Man I'm really pissed with this, I'm trying to fix this for many days, read
uncountable web pages with possible solutions, just tried almos anything...

My project has 1 parent pom and 3 modules, 2 swcs and 1 swf, that holds the
entire project; I really don't see what is wrong in it; even the adobe
framework does not respect the configuration copying libraries, I specified
<rsl>{artifactId}-{version}.{extension}</rsl> in first pom and it copies
only the <rsl>{artifactId}.{extension}</rsl>;

I really wanted to work this out, I'm trying hard almost two weeks and
nothing;












--
View this message in context: http://apache-flex-users.2333346.n4.nabble.com/Flexmojos-Maven-Apache-Flex-Error-1014-tp14976p14997.html
Sent from the Apache Flex Users mailing list archive at Nabble.com.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Flexmojos Maven Apache Flex Error 1014

Christofer Dutz
In reply to this post by rodolpho@essencialcode.com.br
Hi Rodolpho,

Would it be possible to send me the project and I would give a try fixing your issues?

Chris

Am 07.04.17, 18:23 schrieb "[hidden email]" <[hidden email]>:

    Chris, very thanks for your help;
   
    I just did exactly this and many other forms, but it still showing me the
    same error, unfortunetly...
   
    Man I'm really pissed with this, I'm trying to fix this for many days, read
    uncountable web pages with possible solutions, just tried almos anything...
   
    My project has 1 parent pom and 3 modules, 2 swcs and 1 swf, that holds the
    entire project; I really don't see what is wrong in it; even the adobe
    framework does not respect the configuration copying libraries, I specified
    <rsl>{artifactId}-{version}.{extension}</rsl> in first pom and it copies
    only the <rsl>{artifactId}.{extension}</rsl>;
   
    I really wanted to work this out, I'm trying hard almost two weeks and
    nothing;
   
   
   
   
   
   
   
   
   
   
   
   
    --
    View this message in context: http://apache-flex-users.2333346.n4.nabble.com/Flexmojos-Maven-Apache-Flex-Error-1014-tp14976p14997.html
    Sent from the Apache Flex Users mailing list archive at Nabble.com.
   

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Flexmojos Maven Apache Flex Error 1014

rodolpho@essencialcode.com.br
Hello Chris,

Thank you very much for you help; I really appreciate if you can help me;

Please send me your e-mail, I tried here but I could't attach the zipped file;

Thanks a lot Chris !
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Flexmojos Maven Apache Flex Error 1014

Christofer Dutz
Ok … your application should be buildable now … (see your postbox)

Now to the details of what I found:
1. The version of the flex sdk is a 3-segment version (4.15.0) and no longer contains the build number
2. Some of the config options were wrong (FB doesn’t tell you about that and Maven doesn’t complain but IntelliJ helps a lot with this)
3. You were using finalname a lot. I would strongly suggest not to. Because this way “create-rsl” creates a file with a different name than the swc.
4. You were using “external” scope for almost everything … while its ok do to this for things you have rsls for, you shouldn’t use external for things you can’t load as RSL (your crypto lib for example) (Hope this is correct … others please correct me if this was wrong)
5. You were mixing localesCompiled and localesRuntime.

In order to, test your application, I removed the rsl scope and all external scopes to make it build a normally linked swf and the application opened without any errors (ok … there was a big possibly spanish dialog window asking me to click “Ok” or something else (probably Cancel in Spanish or Portugese)

The zip I sent back to you builds successfully on my machine and the application seems to work without Flashplayer errors. I would suggest to take this as a starting point for further optimizations (rsls, external linking, localesRuntime, …).

I order to get the Flex libs (which are not publically available as maven artifacts) have a look at our Mavenizer tool described here [1]

And make sure your Maven version is not too old and not too new. Flexmojos doesn’t work prior to 3.1.1 and I wouldn’t use it with the newest versions (I used 3.3.1 for your application)

Hope that helps. Happy flexing (

Chris


[1]: https://cwiki.apache.org/confluence/display/FLEX/Apache+Flex+SDK+Mavenizer


Am 10.04.17, 22:34 schrieb "[hidden email]" <[hidden email]>:

    Hello Chris,
   
    Thank you very much for you help; I really appreciate if you can help me;
   
    Please send me your e-mail, I tried here but I could't attach the zipped
    file;
   
    Thanks a lot Chris !
   
   
   
    --
    View this message in context: http://apache-flex-users.2333346.n4.nabble.com/Flexmojos-Maven-Apache-Flex-Error-1014-tp14976p15013.html
    Sent from the Apache Flex Users mailing list archive at Nabble.com.
   

Loading...