Quantcast

[FlexJS - maven]: compiled from source, but settings and ../lib/* missing

classic Classic list List threaded Threaded
21 messages Options
12
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[FlexJS - maven]: compiled from source, but settings and ../lib/* missing

davide.prina
Ok, I have compiled all with Maven (as I wrote in the "[FlexJs]: Error: Unable to access jarfile flex-asjs/js/bin/../lib/mxmlc.jar" thread).

But now I don't have bin directory in path, I don't have settings, ...

For example:
$ cd /home/flex/FlexJS_maven/flex-asjs/js/bin
$ ./asjsc
Using Falcon codebase: ./../..
Using Flex SDK: ./../..
Error: Unable to access jarfile ./../lib/mxmlc.jar

This jar don't exists in all maven build tree.

So I have:
$ mkdir ../lib

copied the .jar file build with ant here

but now I have
$ LANG=en_EN ./asjsc
Using Falcon codebase: ./../..
Using Flex SDK: ./../..
Error: Could not find or load main class flex2.tools.Mxmlc

So I have copied all the "lib" directory that I have build with ant

$ LANG=en_EN ./asjsc
Using Falcon codebase: ./../..
Using Flex SDK: ./../..
Apache Flex Compiler (mxmlc)
Version 4.16.0 build 20170410
Copyright 2017 The Apache Software Foundation.

command line: Error: unknown configuration variable 'js-output-type'

Use 'mxmlc -help' for information about using the command line.



This error is the same I get with the ant build.

I have two question:
1) How can I build the flex-asjs/js/lib directory?
2) why I get the error "unknown configuration variable 'js-output-type'". I have see the .sh file asjsc and I have see that:
java $VMARGS $D32 $SETUP_SH_VMARGS -Dflexcompiler="$FALCON_HOME" -Dflexlib="$FLEX_HOME/frameworks" -jar "$SCRIPT_HOME/../lib/mxmlc.jar" +flexlib="$FLEX_HOME/frameworks" -js-output-type=jsc +configname=js "$@"

I have removed the "-js-output-type=jsc", and I get:

$ LANG=en_EN ./asjsc
Using Falcon codebase: ./../..
Using Flex SDK: ./../..
Loading configuration file /home/flex/FlexJS/FlexJS_maven/flex-asjs/frameworks/js-config.xml
Apache Flex Compiler (mxmlc)
Version 4.16.0 build 20170410
Copyright 2017 The Apache Software Foundation.

/home/flex/FlexJS/FlexJS_maven/flex-asjs/frameworks/js-config.xml(78): Error: unknown configuration variable 'compiler.mxml.children-as-data'

          <children-as-data>true</children-as-data>

Thanks
Davide
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

Christofer Dutz
Hi Davide,

The Maven build doesn’t work the same way the Ant build works. While Ant sort of compiles and copies stuff all over the place the maven build is able to produce a so called “distribution”. In order to build a distribution, you need to compile the “asjs” project with maven and enable the distribution profile:

mvn -s settings-template.xml -DdistributionTargetFolder={pathToDistributionDirectory} -P build-distribution clean install

Just replace “{pathToDistributionDirectory}” with the path to a directory you want the build to produce the distribution to (I would strongly suggest to output it to an empty directory.

See more details here [1]

Chris

[1]: https://cwiki.apache.org/confluence/display/FLEX/Building+FlexJS+with+Maven


Am 13.04.17, 14:58 schrieb "[hidden email]" <[hidden email]>:

    Ok, I have compiled all with Maven (as I wrote in the "[FlexJs]: Error: Unable to access jarfile flex-asjs/js/bin/../lib/mxmlc.jar" thread).
   
    But now I don't have bin directory in path, I don't have settings, ...
   
    For example:
    $ cd /home/flex/FlexJS_maven/flex-asjs/js/bin
    $ ./asjsc
    Using Falcon codebase: ./../..
    Using Flex SDK: ./../..
    Error: Unable to access jarfile ./../lib/mxmlc.jar
   
    This jar don't exists in all maven build tree.
   
    So I have:
    $ mkdir ../lib
   
    copied the .jar file build with ant here
   
    but now I have
    $ LANG=en_EN ./asjsc
    Using Falcon codebase: ./../..
    Using Flex SDK: ./../..
    Error: Could not find or load main class flex2.tools.Mxmlc
   
    So I have copied all the "lib" directory that I have build with ant
   
    $ LANG=en_EN ./asjsc
    Using Falcon codebase: ./../..
    Using Flex SDK: ./../..
    Apache Flex Compiler (mxmlc)
    Version 4.16.0 build 20170410
    Copyright 2017 The Apache Software Foundation.
   
    command line: Error: unknown configuration variable 'js-output-type'
   
    Use 'mxmlc -help' for information about using the command line.
   
   
   
    This error is the same I get with the ant build.
   
    I have two question:
    1) How can I build the flex-asjs/js/lib directory?
    2) why I get the error "unknown configuration variable 'js-output-type'". I have see the .sh file asjsc and I have see that:
    java $VMARGS $D32 $SETUP_SH_VMARGS -Dflexcompiler="$FALCON_HOME" -Dflexlib="$FLEX_HOME/frameworks" -jar "$SCRIPT_HOME/../lib/mxmlc.jar" +flexlib="$FLEX_HOME/frameworks" -js-output-type=jsc +configname=js "$@"
   
    I have removed the "-js-output-type=jsc", and I get:
   
    $ LANG=en_EN ./asjsc
    Using Falcon codebase: ./../..
    Using Flex SDK: ./../..
    Loading configuration file /home/flex/FlexJS/FlexJS_maven/flex-asjs/frameworks/js-config.xml
    Apache Flex Compiler (mxmlc)
    Version 4.16.0 build 20170410
    Copyright 2017 The Apache Software Foundation.
   
    /home/flex/FlexJS/FlexJS_maven/flex-asjs/frameworks/js-config.xml(78): Error: unknown configuration variable 'compiler.mxml.children-as-data'
   
              <children-as-data>true</children-as-data>
   
    Thanks
    Davide
   

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

davide.prina
Hi Christofer,

Christofer Dutz ha scritto:

> mvn -s settings-template.xml -DdistributionTargetFolder={pathToDistributionDirectory} -P build-distribution clean install

Ok, I try to do this, but there are a lot of file missing in the repository
I have found most of them into http://repository.jspresso.org/maven2/com/adobe
but some are missing also here:

[ERROR] Failed to execute goal on project distribution: Could not resolve dependencies for project org.apache.flex.flexjs.framework:distribution:pom:0.8.0-SNAPSHOT: The following artifacts could not be resolved: com.adobe.air.runtime:air-runtime:zip:20.0, com.adobe.air.runtime:air:zip:android:20.0, com.adobe.air:templates:jar:20.0, com.adobe.air:misc:zip:20.0: Failure to find com.adobe.air.runtime:air-runtime:zip:20.0 in https://repository.apache.org/content/repositories/releases was cached in the local repository, resolution will not be reattempted until the update interval of apache-release has elapsed or updates are forced -> [Help 1]

where can I find they?

Thanks
Davide
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

piotrz
Davide,

I'm not sure what could cause that problem - did you try couple of times?

One more question - what would you like achieve once you build distribution? How you wanted to use it?

Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

davide.prina
Hi Piotrz,

piotrz ha scritto:

> I'm not sure what could cause that problem - did you try couple of times?

yes, I try a lot of time :-(

If I don't mistake I need these file:

$ find . -name *.lastUpdated
./misc/20.0/misc-20.0.zip.lastUpdated
./misc/20.0/misc-20.0.pom.lastUpdated
./runtime/air/20.0/air-20.0.pom.lastUpdated
./runtime/air/20.0/air-20.0-android.zip.lastUpdated
./runtime/air-runtime/20.0/air-runtime-20.0.zip.lastUpdated
./templates/20.0/templates-20.0.pom.lastUpdated
./templates/20.0/templates-20.0.jar.lastUpdated


[...]
[DEBUG] Using transporter WagonTransporter with priority -1.0 for https://repo.maven.apache.org/maven2
[DEBUG] Using connector BasicRepositoryConnector with priority 0.0 for https://repo.maven.apache.org/maven2 via CENSORED:CENSORED with username=CENSORED, password=***
Downloading: https://repo.maven.apache.org/maven2/com/adobe/air/runtime/air/20.0/air-20.0.pom
[DEBUG] Writing tracking file /home/flex/.m2/repository/com/adobe/air/runtime/air/20.0/air-20.0.pom.lastUpdated
[INFO] Couldn't find artifact: com.adobe.air.runtime:20.0:air:pom
[...]

If a put in a browser this address:
https://repo.maven.apache.org/maven2/com/adobe/air/runtime/air/20.0/air-20.0.pom
I get: 404 Not Found

So the file required is not present in the apache repository...

Where can I find they?

> One more question - what would you like achieve once you build distribution?
> How you wanted to use it?

I would like to test the conversion tools from flex to javascript/html.

Here we have (we have had) a lot of flex projects. I would like to see if they can be converted (partially?) into javascript/html with FlexJS.

Thanks
Davide
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

piotrz
Hi Davide,

Well FlexJS won't exactly convert your project you most likely will have to rewrite your UI part to FlexJS. Only pure AS3 without any dependencies to Flash can be converted to JS through FalconJX.

Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

davide.prina
Hi Piotr,

piotrz ha scritto:

> Well FlexJS won't exactly convert your project you most likely will have to
> rewrite your UI part to FlexJS. Only pure AS3 without any dependencies to
> Flash can be converted to JS through FalconJX.

OK, I know that not all can be converted with FlexJS.

What I want to know is what FlexJS can do to projects we have.

Flash, and so Flex, is about to be unusable on recent major browsers. I work for a local government and we want to know if there is some way to partially automatize the "translation" to Javascript/HTML of the last projects written in Flex we have.

But I don't understand how the maven compilation can ask for files that are not in the Apache Nexus repository.
I have searched they on other Nexus repositories (Adobe, ...), but these are not present. I'm unable to find they.
This is already know or there is need to open a bug report?

Ciao
Davide
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

piotrz
Chris,

That's really strange that those files are not available. Maybe we have to have switch to newest version of adobe air files etc. ?

Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

Christofer Dutz
Hi Guys,

The files you are talking about will not be available in any public repo. That’s what the entire “mavenizer” or “flex-maven-converter” is for.
It detects that Maven tries to resolve one of the flash or air or forntkit libraries and if that fails, it auto-downloads the corresponding libs and converts them to maven accessible artifacts. You can see that the mavenizer is working, if you see the Flex Ascii Art logo in the build.

Chris

Am 14.04.17, 16:21 schrieb "piotrz" <[hidden email]>:

    Chris,
   
    That's really strange that those files are not available. Maybe we have to
    have switch to newest version of adobe air files etc. ?
   
    Piotr
   
   
   
    -----
    Apache Flex PMC
    [hidden email]
    --
    View this message in context: http://apache-flex-users.2333346.n4.nabble.com/FlexJS-maven-compiled-from-source-but-settings-and-lib-missing-tp15045p15054.html
    Sent from the Apache Flex Users mailing list archive at Nabble.com.
   

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

davide.prina
Hi Christofer,

Christofer Dutz ha scritto:

> The files you are talking about will not be available in any public repo. That’s what the entire “mavenizer”
> or “flex-maven-converter” is for.

ok

> It detects that Maven tries to resolve one of the flash or air or forntkit libraries and if that fails, it
> auto-downloads the corresponding libs and converts them to maven accessible artifacts.

interesting, but how can I see if there is some problem donwloading or mavenizing these libs?

> You can see that the mavenizer is working, if you see the Flex Ascii Art logo in the build.

Yes I can se it.


I have executed it with debug info on:

$ mvn -e -X -s settings-template.xml -DdistributionTargetFolder=~/FlexJS_maven/FlexJS_bin -P build-distribution clean install
[...]
[DEBUG] Using transporter WagonTransporter with priority -1.0 for https://repo.maven.apache.org/maven2
[DEBUG] Using connector BasicRepositoryConnector with priority 0.0 for https://repo.maven.apache.org/maven2 via IP-REMOVED:PORT-REMOVED with username=REMOVED, password=REMOVED
Downloading: https://repo.maven.apache.org/maven2/com/adobe/air/runtime/air/20.0/air-20.0.pom
[DEBUG] Writing tracking file /home/flex/.m2/repository/com/adobe/air/runtime/air/20.0/air-20.0.pom.lastUpdated
[INFO] Couldn't find artifact: com.adobe.air.runtime:20.0:air:pom
[INFO] ===========================================================
[INFO]  - Installing Adobe AIR SDK 20.0
Your System-Id: 429d5384
The Adobe SDK license agreement applies to the Adobe AIR SDK. Do you want to install the Adobe AIR SDK? Adobe AIR SDK License: http://www.adobe.com/products/air/sdk-eula.html
(In a non-interactive build such as a CI server build, alternatively to typing y or yes you can also set a system property containing your system which is interpreted as equivalent to accepting by typing y or yes: -Dcom.adobe.systemIdsForWhichTheTermsOfTheAdobeLicenseAgreementAreAccepted=429d5384 )
Do you accept (Yes/No) ? yes
Using proxy: IP-REMOVED
[WARNING] Failed to notify spy org.apache.flex.utilities.converter.mavenextension.FlexEventSpy: Caught exception while downloading and converting artifact.
org.apache.maven.MavenExecutionException: Caught exception while downloading and converting artifact.
        at org.apache.flex.utilities.converter.mavenextension.FlexEventSpy.initAir(FlexEventSpy.java:245)
        at org.apache.flex.utilities.converter.mavenextension.FlexEventSpy.onEvent(FlexEventSpy.java:141)
        at org.apache.maven.eventspy.internal.EventSpyDispatcher.onEvent(EventSpyDispatcher.java:104)
        at org.apache.maven.eventspy.internal.EventSpyRepositoryListener.artifactResolving(EventSpyRepositoryListener.java:95)
        at org.eclipse.aether.internal.impl.DefaultRepositoryEventDispatcher.dispatch(DefaultRepositoryEventDispatcher.java:139)
        at org.eclipse.aether.internal.impl.DefaultRepositoryEventDispatcher.dispatch(DefaultRepositoryEventDispatcher.java:101)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.artifactResolving(DefaultArtifactResolver.java:662)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:276)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223)
        at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:267)
        at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.readArtifactDescriptor(DefaultArtifactDescriptorReader.java:198)
        at org.eclipse.aether.internal.impl.DefaultDependencyCollector.resolveCachedArtifactDescriptor(DefaultDependencyCollector.java:535)
        at org.eclipse.aether.internal.impl.DefaultDependencyCollector.getArtifactDescriptorResult(DefaultDependencyCollector.java:519)
        at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:409)
        at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:363)
        at org.eclipse.aether.internal.impl.DefaultDependencyCollector.process(DefaultDependencyCollector.java:351)
        at org.eclipse.aether.internal.impl.DefaultDependencyCollector.collectDependencies(DefaultDependencyCollector.java:254)
        at org.eclipse.aether.internal.impl.DefaultRepositorySystem.collectDependencies(DefaultRepositorySystem.java:316)
        at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:172)
        at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:195)
        at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.resolveProjectDependencies(LifecycleDependencyResolver.java:128)
        at org.apache.maven.lifecycle.internal.MojoExecutor.ensureDependenciesAreResolved(MojoExecutor.java:245)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:199)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
        at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
        at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
        at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
Caused by: org.apache.flex.utilities.converter.retrievers.exceptions.RetrieverException: Could not find AIR SDK with version 20.0
        at org.apache.flex.utilities.converter.retrievers.download.DownloadRetriever.getBinaryUrl(DownloadRetriever.java:362)
        at org.apache.flex.utilities.converter.retrievers.download.DownloadRetriever.retrieve(DownloadRetriever.java:120)
        at org.apache.flex.utilities.converter.mavenextension.FlexEventSpy.initAir(FlexEventSpy.java:241)
        ... 43 more
[...]


But it cannot download the file:
https://repo.maven.apache.org/maven2/com/adobe/air/runtime/air/20.0/air-20.0.pom

and if I try this address on a browser I get the "404 Not Found" message.

$ cat /home/flex/.m2/repository/com/adobe/air/runtime/air/20.0/air-20.0.pom.lastUpdated
#NOTE: This is an Aether internal implementation file, its format can be changed without prior notice.
#Fri Apr 14 10:46:20 CEST 2017
https\://repository.apache.org/content/repositories/releases/.error=
https\://repo.maven.apache.org/maven2/.lastUpdated=1492155569143
https\://repository.apache.org/content/repositories/releases/.lastUpdated=1492159580279
https\://repo.maven.apache.org/maven2/.error=

So where is the problme? Is it the missing pom file?
Probably something do not function coorectly, may be becouse I pass throught a proxy with password... or something else...

How can I solve this problem?

Can I create manually the missing files? How?

Ciao
Davide

PS: sorry, I know nearly nothing about maven :-(
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

Christofer Dutz
Unfortunately you didn’t post the most interesting part … could you also please post the “Caused by” parts of the stacktrace?

Chris

Am 18.04.17, 09:28 schrieb "[hidden email]" <[hidden email]>:

    at org.apache.flex.utilities.converter.retrievers.download.DownloadRetriever.retrieve(DownloadRetriever.java:120)
   
   

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

Christofer Dutz
In reply to this post by davide.prina
Havin a more detailed look, I think I know what’s going on:

Well as I said, the mavenizer hooks itself into the Maven dependency resolution mechanism: Part of what it does is to try to resolve the things first (In a company you can deploy a mavenized SDK to your company or private Maven repo: Nexus, Artifactory whatsoever) so if your infrastructure is able to provide the artifact, all is good and it doesn’t interfere. In your case you don’t seem to have a company maven repository manager running so it’s checking the default, which is maven-central (repo.maven.apache.org). Of course it doesn’t exist there and therefore it would start to do its magic. As far as I can see things from the stacktrace fragment you sent, the mavenizer downloaded our xml file containing the information on where to download the artifacts from, but couldn’t find the product you were trying to find. Judging from the location of your local maven repo, you are using a Linux based system … I guess this is where the problem is. There is no LINUX based Air 20.0 available from Adobe … The only option I see here is, that you “skip-tests” and force the tool to use the Windows or Mac version by  setting a SystemProperty “platform-type” to WINDOWS: “-Dplatform-type=WINDOWS” or “-Dplatform-type=MAC”

Chris



-

Am 18.04.17, 09:28 schrieb "[hidden email]" <[hidden email]>:

    Hi Christofer,
   
    Christofer Dutz ha scritto:
   
    > The files you are talking about will not be available in any public repo. That’s what the entire “mavenizer”
    > or “flex-maven-converter” is for.
   
    ok
   
    > It detects that Maven tries to resolve one of the flash or air or forntkit libraries and if that fails, it
    > auto-downloads the corresponding libs and converts them to maven accessible artifacts.
   
    interesting, but how can I see if there is some problem donwloading or mavenizing these libs?
   
    > You can see that the mavenizer is working, if you see the Flex Ascii Art logo in the build.
   
    Yes I can se it.
   
   
    I have executed it with debug info on:
   
    $ mvn -e -X -s settings-template.xml -DdistributionTargetFolder=~/FlexJS_maven/FlexJS_bin -P build-distribution clean install
    [...]
    [DEBUG] Using transporter WagonTransporter with priority -1.0 for https://repo.maven.apache.org/maven2
    [DEBUG] Using connector BasicRepositoryConnector with priority 0.0 for https://repo.maven.apache.org/maven2 via IP-REMOVED:PORT-REMOVED with username=REMOVED, password=REMOVED
    Downloading: https://repo.maven.apache.org/maven2/com/adobe/air/runtime/air/20.0/air-20.0.pom
    [DEBUG] Writing tracking file /home/flex/.m2/repository/com/adobe/air/runtime/air/20.0/air-20.0.pom.lastUpdated
    [INFO] Couldn't find artifact: com.adobe.air.runtime:20.0:air:pom
    [INFO] ===========================================================
    [INFO]  - Installing Adobe AIR SDK 20.0
    Your System-Id: 429d5384
    The Adobe SDK license agreement applies to the Adobe AIR SDK. Do you want to install the Adobe AIR SDK? Adobe AIR SDK License: http://www.adobe.com/products/air/sdk-eula.html
    (In a non-interactive build such as a CI server build, alternatively to typing y or yes you can also set a system property containing your system which is interpreted as equivalent to accepting by typing y or yes: -Dcom.adobe.systemIdsForWhichTheTermsOfTheAdobeLicenseAgreementAreAccepted=429d5384 )
    Do you accept (Yes/No) ? yes
    Using proxy: IP-REMOVED
    [WARNING] Failed to notify spy org.apache.flex.utilities.converter.mavenextension.FlexEventSpy: Caught exception while downloading and converting artifact.
    org.apache.maven.MavenExecutionException: Caught exception while downloading and converting artifact.
    at org.apache.flex.utilities.converter.mavenextension.FlexEventSpy.initAir(FlexEventSpy.java:245)
    at org.apache.flex.utilities.converter.mavenextension.FlexEventSpy.onEvent(FlexEventSpy.java:141)
    at org.apache.maven.eventspy.internal.EventSpyDispatcher.onEvent(EventSpyDispatcher.java:104)
    at org.apache.maven.eventspy.internal.EventSpyRepositoryListener.artifactResolving(EventSpyRepositoryListener.java:95)
    at org.eclipse.aether.internal.impl.DefaultRepositoryEventDispatcher.dispatch(DefaultRepositoryEventDispatcher.java:139)
    at org.eclipse.aether.internal.impl.DefaultRepositoryEventDispatcher.dispatch(DefaultRepositoryEventDispatcher.java:101)
    at org.eclipse.aether.internal.impl.DefaultArtifactResolver.artifactResolving(DefaultArtifactResolver.java:662)
    at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:276)
    at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
    at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223)
    at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:267)
    at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.readArtifactDescriptor(DefaultArtifactDescriptorReader.java:198)
    at org.eclipse.aether.internal.impl.DefaultDependencyCollector.resolveCachedArtifactDescriptor(DefaultDependencyCollector.java:535)
    at org.eclipse.aether.internal.impl.DefaultDependencyCollector.getArtifactDescriptorResult(DefaultDependencyCollector.java:519)
    at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:409)
    at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:363)
    at org.eclipse.aether.internal.impl.DefaultDependencyCollector.process(DefaultDependencyCollector.java:351)
    at org.eclipse.aether.internal.impl.DefaultDependencyCollector.collectDependencies(DefaultDependencyCollector.java:254)
    at org.eclipse.aether.internal.impl.DefaultRepositorySystem.collectDependencies(DefaultRepositorySystem.java:316)
    at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:172)
    at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:195)
    at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.resolveProjectDependencies(LifecycleDependencyResolver.java:128)
    at org.apache.maven.lifecycle.internal.MojoExecutor.ensureDependenciesAreResolved(MojoExecutor.java:245)
    at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:199)
    at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
    at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
    at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
    at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
    at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
    at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
    at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
    at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
    at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
    at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
    at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
    at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
    at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
    at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
    at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
    Caused by: org.apache.flex.utilities.converter.retrievers.exceptions.RetrieverException: Could not find AIR SDK with version 20.0
    at org.apache.flex.utilities.converter.retrievers.download.DownloadRetriever.getBinaryUrl(DownloadRetriever.java:362)
    at org.apache.flex.utilities.converter.retrievers.download.DownloadRetriever.retrieve(DownloadRetriever.java:120)
    at org.apache.flex.utilities.converter.mavenextension.FlexEventSpy.initAir(FlexEventSpy.java:241)
    ... 43 more
    [...]
   
   
    But it cannot download the file:
    https://repo.maven.apache.org/maven2/com/adobe/air/runtime/air/20.0/air-20.0.pom
   
    and if I try this address on a browser I get the "404 Not Found" message.
   
    $ cat /home/flex/.m2/repository/com/adobe/air/runtime/air/20.0/air-20.0.pom.lastUpdated
    #NOTE: This is an Aether internal implementation file, its format can be changed without prior notice.
    #Fri Apr 14 10:46:20 CEST 2017
    https\://repository.apache.org/content/repositories/releases/.error=
    https\://repo.maven.apache.org/maven2/.lastUpdated=1492155569143
    https\://repository.apache.org/content/repositories/releases/.lastUpdated=1492159580279
    https\://repo.maven.apache.org/maven2/.error=
   
    So where is the problme? Is it the missing pom file?
    Probably something do not function coorectly, may be becouse I pass throught a proxy with password... or something else...
   
    How can I solve this problem?
   
    Can I create manually the missing files? How?
   
    Ciao
    Davide
   
    PS: sorry, I know nearly nothing about maven :-(
   

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

davide.prina
In reply to this post by Christofer Dutz
Hi Christofer,

Christofer Dutz ha scritto:

> Unfortunately you didn’t post the most interesting part … could you also please post
> the “Caused by” parts of the stacktrace?

there is not this part immediately following, but there is that at the end of the compilation process:

Caused by: org.apache.maven.project.DependencyResolutionException: Could not resolve dependencies for project org.apache.flex.flexjs.framework:distribution:pom:0.8.0-SNAPSHOT: The following artifacts could not be resolved: com.adobe.air.runtime:air-runtime:zip:20.0, com.adobe.air.runtime:air:zip:android:20.0, com.adobe.air:templates:jar:20.0, com.adobe.air:misc:zip:20.0: Could not find artifact com.adobe.air.runtime:air-runtime:zip:20.0 in apache-release (https://repository.apache.org/content/repositories/releases)
        at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:212)
        at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:195)
        ... 23 more
Caused by: org.eclipse.aether.resolution.DependencyResolutionException: The following artifacts could not be resolved: com.adobe.air.runtime:air-runtime:zip:20.0, com.adobe.air.runtime:air:zip:android:20.0, com.adobe.air:templates:jar:20.0, com.adobe.air:misc:zip:20.0: Could not find artifact com.adobe.air.runtime:air-runtime:zip:20.0 in apache-release (https://repository.apache.org/content/repositories/releases)
        at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:384)
        at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:205)
        ... 24 more
Caused by: org.eclipse.aether.resolution.ArtifactResolutionException: The following artifacts could not be resolved: com.adobe.air.runtime:air-runtime:zip:20.0, com.adobe.air.runtime:air:zip:android:20.0, com.adobe.air:templates:jar:20.0, com.adobe.air:misc:zip:20.0: Could not find artifact com.adobe.air.runtime:air-runtime:zip:20.0 in apache-release (https://repository.apache.org/content/repositories/releases)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
        at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:367)
        ... 25 more
Caused by: org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact com.adobe.air.runtime:air-runtime:zip:20.0 in apache-release (https://repository.apache.org/content/repositories/releases)
        at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:39)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355)
        at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:67)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
[ERROR]
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :distribution


Now I try to do what you have write in the second reply.

Thanks
Davide
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

Christofer Dutz
Hi Davide,

If you are running on Linux you will not be able to do an Android packaging, as this works in AIR by Adobe bundling parts of the Google Android SDK in the AIR SDK for doing the packaging. As there is no Linux AIR SDK you will not be able to do this. I was working on some trick to make it work on Linux because Google provides Linux Android SDKs. The Java libs in the AIR SDK should be able to run on Linux too if the required Linux versions of some binaries are available in the right places, but reverse-engineering the requirements for this was a nightmare so I gave up on this (

Chris

 

Am 18.04.17, 10:10 schrieb "[hidden email]" <[hidden email]>:

    Hi Christofer,
   
    Christofer Dutz ha scritto:
   
    > Unfortunately you didn’t post the most interesting part … could you also please post
    > the “Caused by” parts of the stacktrace?
   
    there is not this part immediately following, but there is that at the end of the compilation process:
   
    Caused by: org.apache.maven.project.DependencyResolutionException: Could not resolve dependencies for project org.apache.flex.flexjs.framework:distribution:pom:0.8.0-SNAPSHOT: The following artifacts could not be resolved: com.adobe.air.runtime:air-runtime:zip:20.0, com.adobe.air.runtime:air:zip:android:20.0, com.adobe.air:templates:jar:20.0, com.adobe.air:misc:zip:20.0: Could not find artifact com.adobe.air.runtime:air-runtime:zip:20.0 in apache-release (https://repository.apache.org/content/repositories/releases)
    at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:212)
    at org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependencies(LifecycleDependencyResolver.java:195)
    ... 23 more
    Caused by: org.eclipse.aether.resolution.DependencyResolutionException: The following artifacts could not be resolved: com.adobe.air.runtime:air-runtime:zip:20.0, com.adobe.air.runtime:air:zip:android:20.0, com.adobe.air:templates:jar:20.0, com.adobe.air:misc:zip:20.0: Could not find artifact com.adobe.air.runtime:air-runtime:zip:20.0 in apache-release (https://repository.apache.org/content/repositories/releases)
    at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:384)
    at org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(DefaultProjectDependenciesResolver.java:205)
    ... 24 more
    Caused by: org.eclipse.aether.resolution.ArtifactResolutionException: The following artifacts could not be resolved: com.adobe.air.runtime:air-runtime:zip:20.0, com.adobe.air.runtime:air:zip:android:20.0, com.adobe.air:templates:jar:20.0, com.adobe.air:misc:zip:20.0: Could not find artifact com.adobe.air.runtime:air-runtime:zip:20.0 in apache-release (https://repository.apache.org/content/repositories/releases)
    at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444)
    at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
    at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:367)
    ... 25 more
    Caused by: org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact com.adobe.air.runtime:air-runtime:zip:20.0 in apache-release (https://repository.apache.org/content/repositories/releases)
    at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:39)
    at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355)
    at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:67)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
    [ERROR]
    [ERROR]
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
    [ERROR]
    [ERROR] After correcting the problems, you can resume the build with the command
    [ERROR]   mvn <goals> -rf :distribution
   
   
    Now I try to do what you have write in the second reply.
   
    Thanks
    Davide
   

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

davide.prina
In reply to this post by Christofer Dutz
Hi Christofer,

Christofer Dutz ha scritto:

> Judging from the location of your local maven repo, you are using a Linux based system

yes
I'm using Debian Stretch GNU/Linux

>  … I guess this is where the problem is. There is no LINUX based Air 20.0 available from Adobe …

:-(

> The only option I see here is, that you “skip-tests” and force the tool to use the Windows or Mac
> version by  setting a SystemProperty “platform-type” to WINDOWS: “-Dplatform-type=WINDOWS” or “-Dplatform-type=MAC”

I have try, I have see it has download some file for windows, but then I have the same errors for the same files.

I don't use windows and I don't know how to use it... I will try to ask to someone else in my company.

thanks for all
Davide

__________________________________

Davide Prina, PMP
Area Architettura Applicativa e Basi Dati Sire
Direzione Project Management e Tecnologie Applicative

Lombardia Informatica S.p.A.
Via Torquato Taramelli, 26
20124 Milano ITALY
www.lispa.it

Mail: [hidden email]
Office: +39 02 39331 348
__________________________________

Le informazioni contenute in questo messaggio e ogni documento o file ad esso allegato sono riservati e confidenziali. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio o a diversa persona da questo autorizzata, per le finalità indicate nel messaggio medesimo. Qualora Lei non fosse la persona cui il presente messaggio è destinato, La invitiamo a eliminarlo dal Suo Sistema e a distruggere le varie copie o stampe, dandocene gentilmente comunicazione. Ogni utilizzo improprio è contrario ai principi del D.Lgs. 196/03 e alla legislazione europea (Direttiva 2002/58/CE). Lombardia Informatica S.p.A. opera in conformità al D.Lgs. 196/2003 citato. Per qualsiasi informazione a riguardo si prega di contattare la nostra Società al seguente indirizzo e-mail: [hidden email]

The information contained in this message, as well as any attached file(s), is private and confidential and is only intended for the person to whom it is addressed. If the reader of this message is not the intended recipient or the employee or agent responsible for delivering the message to the intended recipient, or you have received this communication in error, please be aware that any dissemination, distribution or duplication is strictly prohibited, and may be illegal. Please notify us immediately and delete all copies from your mailbox and other archives. Thank you.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

patrizia.bellitto
In reply to this post by davide.prina
Hello Davide,
I have your same issue: the mxmlc.jar does not exist inside the directory js/lib, so I copied all the the content from the lib, but now the error changes to  command line: Error: unknown configuration variable 'js-output-type'.

Were you able to fix it?

Thanks
Patrizia
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

Christofer Dutz
This sounds like you are using an older version of the compiler with a newer version of the maven plugin.
Currently configuration is changing a lot and you should always use the same version of compiler as you are using in the plugin.

But what are you doing exactly. Maven doesn’t require you to have anything installed locally, you only need that if you are building with FlashBuilder or Ant.

Chris



Am 15.05.17, 09:38 schrieb "patrizia.bellitto" <[hidden email]>:

    Hello Davide,
    I have your same issue: the mxmlc.jar does not exist inside the directory
    js/lib, so I copied all the the content from the lib, but now the error
    changes to  command line: Error: unknown configuration variable
    'js-output-type'.
   
    Were you able to fix it?
   
    Thanks
    Patrizia
   
   
   
    --
    View this message in context: http://apache-flex-users.2333346.n4.nabble.com/FlexJS-maven-compiled-from-source-but-settings-and-lib-missing-tp15045p15233.html
    Sent from the Apache Flex Users mailing list archive at Nabble.com.
   

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

patrizia.bellitto
Hello Cristopher,
thanks for your answer, sorry but I saw it only now.
I obtained that error with Ant on Windows, not with Maven.
I'm trying again right now with Maven on MacOS, let's see if I have the same problems.

THanks
Patrizia
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

patrizia.bellitto
Hi Christofer,
I was able to compile everything both with Maven and Ant on MacOS.
Then I followed the instructions to use FlexJS within Flash Builder 4.7 (https://cwiki.apache.org/confluence/display/FLEX/Using+FlexJS+with+Adobe+Flash+Builder).


The release 0.8.0 I build through Maven returns this error when converting the simple Flex project to FlexJS project:

The file does not exist for the external tool named Convert New Flex Project to FlexJS MVC Project.

while with the release 0.7.0 compiled with Ant I can convert the project to a FlexJS project, but, trying to launch the Falcon JX release and build configuration the error is:

Using Falcon codebase: /Users/pbellitto/Sviluppo/apache-flex-flexjs-0.7.0-ant/js/bin/../..
Using Flex SDK: /Users/pbellitto/Sviluppo/apache-flex-flexjs-0.7.0-ant/js/bin/../..
Error: Unable to access jarfile /Users/pbellitto/Sviluppo/apache-flex-flexjs-0.7.0-ant/js/bin/../lib/mxmlc.jar


that is the same problem I had on Windows.
I'm using the latest releases of Maven and Ant.

Thanks
Patrizia
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS - maven]: compiled from source, but settings and ../lib/* missing

Alex Harui-2
Hi Patrizia,

If you are using Ant to build something from sources to be used in an IDE
like Flash Builder, you will need to run "ant release -Dnightly=true"
which will create artifacts in the "out" folder that you then expand into
an empty folder and run "ant -f installer.xml"

I'm not sure we've got all of the kinds worked out from the Maven build
for making an IDE compatible package.

Thanks,
-Alex

On 5/23/17, 6:25 AM, "patrizia.bellitto" <[hidden email]> wrote:

>Hi Christofer,
>I was able to compile everything both with Maven and Ant on MacOS.
>Then I followed the instructions to use FlexJS within Flash Builder 4.7
>(https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fcwiki.ap
>ache.org%2Fconfluence%2Fdisplay%2FFLEX%2FUsing%2BFlexJS%2Bwith%2BAdobe%2BF
>lash%2BBuilder&data=02%7C01%7C%7Ca62f1553c936422716d308d4a1e12bbf%7Cfa7b1b
>5a7b34438794aed2c178decee1%7C0%7C0%7C636311435863437429&sdata=MGdZsy3kLDBZ
>C7n4KORLLbMaocm140e21uEKLBiO0mA%3D&reserved=0).
>
>
>The release 0.8.0 I build through Maven returns this error when converting
>the simple Flex project to FlexJS project:
>
>The file does not exist for the external tool named Convert New Flex
>Project
>to FlexJS MVC Project.
>
>while with the release 0.7.0 compiled with Ant I can convert the project
>to
>a FlexJS project, but, trying to launch the Falcon JX release and build
>configuration the error is:
>
>Using Falcon codebase:
>/Users/pbellitto/Sviluppo/apache-flex-flexjs-0.7.0-ant/js/bin/../..
>Using Flex SDK:
>/Users/pbellitto/Sviluppo/apache-flex-flexjs-0.7.0-ant/js/bin/../..
>Error: Unable to access jarfile
>/Users/pbellitto/Sviluppo/apache-flex-flexjs-0.7.0-ant/js/bin/../lib/mxmlc
>.jar
>
>
>that is the same problem I had on Windows.
>I'm using the latest releases of Maven and Ant.
>
>Thanks
>Patrizia
>
>
>
>--
>View this message in context:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-fle
>x-users.2333346.n4.nabble.com%2FFlexJS-maven-compiled-from-source-but-sett
>ings-and-lib-missing-tp15045p15256.html&data=02%7C01%7C%7Ca62f1553c9364227
>16d308d4a1e12bbf%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636311435863
>447438&sdata=YhFYOrgCeFYr0ALIWfUlYyYLBQQDhm6f6M4IdYa0Wxk%3D&reserved=0
>Sent from the Apache Flex Users mailing list archive at Nabble.com.

12
Loading...