Flex installer: Problem installing AIR SDK

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Flex installer: Problem installing AIR SDK

appsperimental
Hello,

I tried several times over the last days to install flex, but I'm not able to download the AIR SDK 25.

Here are the log messages:

Installer version 3.2.0 (windows)
Using Locale: de_DE
Ermitteln von mirror URL über CGI-Skript erfolgreich.
SDK version Apache Flex SDK 4.16.0
AIR version 24.0
Flash Player version 24.0
Erstelle Apache Flex home
Erstelle Temp Verzeichnis
Lade Apache Flex SDK von: http://mirror.softaculous.com/apache/flex/4.16.0/binaries/apache-flex-sdk-4.16.0-bin.zip
Verifiziere Apache Flex SDK MD5 Signature
Die Signatur der heruntergeladenen Dateien stimmt mit der Apache Flex SDK MD5 Signatur überein. Die Datei ist gültig.
Entpacke: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\Apache 4.16.0 mit AIR24\temp\apache-flex-sdk-4.16.0-bin.zip
entpacken abgeschlossen: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\Apache 4.16.0 mit AIR24\temp\apache-flex-sdk-4.16.0-bin.zip
Lade Adobe AIR Runtime Kit für Windows von: http://airdownload.adobe.com/air/win/download/24.0//AdobeAIRSDK.zip
Validating download: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\Apache 4.16.0 mit AIR24/in/AdobeAIRSDK.zip
AIR SDK download failed

When I try to install the AIR SDK manually, I get an error too (url: https://airdownload.adobe.com/air/win/download/latest/AIRSDK_Compiler.zip, error: ERR_CONNECTION_TIMED_OUT).

Is there another source for the latest AIR SDK? And can I somehow install the Flex SDK without AIR and copy the AIR ressources into the folder afterwards?

Thank you for your help!
Reply | Threaded
Open this post in threaded view
|

Re: Flex installer: Problem installing AIR SDK

Josh Tynjala
I'm not sure why you're getting timeouts from Adobe's website. However, I
just wanted to point out that you don't want the AIRSDK_Compiler.zip file.
That's the AIR SDK with the ASC 2.0 compiler. If you try to merge that with
a Flex SDK, you'll get a weird mix of two different compilers, and that
could break something.

You want the version of the AIR SDK that contains only the AIR SDK and no
compiler. When you go to the AIR SDK download page, look for the the
section where it says "Note: Flex users will need to download the original
AIR SDK without the new compiler."

http://www.adobe.com/devnet/air/air-sdk-download.html

- Josh

On Mon, May 15, 2017 at 9:24 AM, appsperimental <
[hidden email]> wrote:

> Hello,
>
> I tried several times over the last days to install flex, but I'm not able
> to download the AIR SDK 25.
>
> Here are the log messages:
>
> Installer version 3.2.0 (windows)
> Using Locale: de_DE
> Ermitteln von mirror URL über CGI-Skript erfolgreich.
> SDK version Apache Flex SDK 4.16.0
> AIR version 24.0
> Flash Player version 24.0
> Erstelle Apache Flex home
> Erstelle Temp Verzeichnis
> Lade Apache Flex SDK von:
> http://mirror.softaculous.com/apache/flex/4.16.0/binaries/
> apache-flex-sdk-4.16.0-bin.zip
> Verifiziere Apache Flex SDK MD5 Signature
> Die Signatur der heruntergeladenen Dateien stimmt mit der Apache Flex SDK
> MD5 Signatur überein. Die Datei ist gültig.
> Entpacke: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64
> Bit)\sdks\Apache 4.16.0 mit AIR24\temp\apache-flex-sdk-4.16.0-bin.zip
> entpacken abgeschlossen: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64
> Bit)\sdks\Apache 4.16.0 mit AIR24\temp\apache-flex-sdk-4.16.0-bin.zip
> Lade Adobe AIR Runtime Kit für Windows von:
> http://airdownload.adobe.com/air/win/download/24.0//AdobeAIRSDK.zip
> Validating download: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64
> Bit)\sdks\Apache 4.16.0 mit AIR24/in/AdobeAIRSDK.zip
> AIR SDK download failed
>
> When I try to install the AIR SDK manually, I get an error too (url:
> https://airdownload.adobe.com/air/win/download/latest/AIRSDK_Compiler.zip,
> error: ERR_CONNECTION_TIMED_OUT).
>
> Is there another source for the latest AIR SDK? And can I somehow install
> the Flex SDK without AIR and copy the AIR ressources into the folder
> afterwards?
>
> Thank you for your help!
>
>
>
> --
> View this message in context: http://apache-flex-users.
> 2333346.n4.nabble.com/Flex-installer-Problem-installing-
> AIR-SDK-tp15238.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Flex installer: Problem installing AIR SDK

Alex Harui-2
I just checked, and my tests show that the installer has the right
checksums for the AIR SDKs.  The SDKs are huge, so some people do have a
better chance of corruption on these big downloads.

One trick to can try is to pre-load the Installer's cache.  If you right
click in the Installer, you can turn on its download cache and pick a
folder for downloads.  Then if you can manually download the AIR SDK you
can place it in the cache.  On my Mac, I have the cache in
/Users/<username>/InstallerCache and AIR 25 is in
air/mac/download/25.0/AdobeAIRSDK.dmg

But you might then run into an out-of-memory issue we are having with the
Installer on Windows.

Another option is to use Ant.  Grab the binary distribution for an Apache
Flex release and unzip it and run:

  ant -f installer.xml -Dflash.sdk.version=25.0 -Dair.sdk.version=25.0

I think you can also install with an older AIR SDK and use shell or batch
files to overlay a new AIR SDK.  I haven't done it myself but see past
email threads where folks explain how to do it.

-Alex

On 5/15/17, 9:42 AM, "Josh Tynjala" <[hidden email]> wrote:

>I'm not sure why you're getting timeouts from Adobe's website. However, I
>just wanted to point out that you don't want the AIRSDK_Compiler.zip file.
>That's the AIR SDK with the ASC 2.0 compiler. If you try to merge that
>with
>a Flex SDK, you'll get a weird mix of two different compilers, and that
>could break something.
>
>You want the version of the AIR SDK that contains only the AIR SDK and no
>compiler. When you go to the AIR SDK download page, look for the the
>section where it says "Note: Flex users will need to download the original
>AIR SDK without the new compiler."
>
>http://www.adobe.com/devnet/air/air-sdk-download.html
>
>- Josh
>
>On Mon, May 15, 2017 at 9:24 AM, appsperimental <
>[hidden email]> wrote:
>
>> Hello,
>>
>> I tried several times over the last days to install flex, but I'm not
>>able
>> to download the AIR SDK 25.
>>
>> Here are the log messages:
>>
>> Installer version 3.2.0 (windows)
>> Using Locale: de_DE
>> Ermitteln von mirror URL über CGI-Skript erfolgreich.
>> SDK version Apache Flex SDK 4.16.0
>> AIR version 24.0
>> Flash Player version 24.0
>> Erstelle Apache Flex home
>> Erstelle Temp Verzeichnis
>> Lade Apache Flex SDK von:
>>
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fmirror.so
>>ftaculous.com%2Fapache%2Fflex%2F4.16.0%2Fbinaries%2F&data=02%7C01%7C%7C72
>>55e9c7f1884ec998b108d49bb186c2%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0
>>%7C636304634149309337&sdata=zk%2BaFsLHtP7juH279rQmYxqn0EQHn2yKiA4lclmKr%2
>>B0%3D&reserved=0
>> apache-flex-sdk-4.16.0-bin.zip
>> Verifiziere Apache Flex SDK MD5 Signature
>> Die Signatur der heruntergeladenen Dateien stimmt mit der Apache Flex
>>SDK
>> MD5 Signatur überein. Die Datei ist gültig.
>> Entpacke: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64
>> Bit)\sdks\Apache 4.16.0 mit AIR24\temp\apache-flex-sdk-4.16.0-bin.zip
>> entpacken abgeschlossen: C:\Program Files\Adobe\Adobe Flash Builder 4.7
>>(64
>> Bit)\sdks\Apache 4.16.0 mit AIR24\temp\apache-flex-sdk-4.16.0-bin.zip
>> Lade Adobe AIR Runtime Kit für Windows von:
>>
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fairdownlo
>>ad.adobe.com%2Fair%2Fwin%2Fdownload%2F24.0%2F%2FAdobeAIRSDK.zip&data=02%7
>>C01%7C%7C7255e9c7f1884ec998b108d49bb186c2%7Cfa7b1b5a7b34438794aed2c178dec
>>ee1%7C0%7C0%7C636304634149309337&sdata=15kE5wJ%2B4J55k2kDPne95ULV0uRXilZe
>>MBVVBX8mvTQ%3D&reserved=0
>> Validating download: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64
>> Bit)\sdks\Apache 4.16.0 mit AIR24/in/AdobeAIRSDK.zip
>> AIR SDK download failed
>>
>> When I try to install the AIR SDK manually, I get an error too (url:
>>
>>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fairdownl
>>oad.adobe.com%2Fair%2Fwin%2Fdownload%2Flatest%2FAIRSDK_Compiler.zip&data=
>>02%7C01%7C%7C7255e9c7f1884ec998b108d49bb186c2%7Cfa7b1b5a7b34438794aed2c17
>>8decee1%7C0%7C0%7C636304634149319346&sdata=g1EY8IpUkXDHDyF2n9GXOy%2FFN3Sz
>>yurdINmWzpoVQCw%3D&reserved=0,
>> error: ERR_CONNECTION_TIMED_OUT).
>>
>> Is there another source for the latest AIR SDK? And can I somehow
>>install
>> the Flex SDK without AIR and copy the AIR ressources into the folder
>> afterwards?
>>
>> Thank you for your help!
>>
>>
>>
>> --
>> View this message in context: http://apache-flex-users.
>> 2333346.n4.nabble.com/Flex-installer-Problem-installing-
>> AIR-SDK-tp15238.html
>> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>>