Flex iPad app no longer installs

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Flex iPad app no longer installs

robertB
Has anyone else had this problem and can point to where I should look for a fix?

My Flex iPad app (equationlab.net) no longer deploys to iPad with iOS 10.3.2 from FlashBuilder 4.7 using Flex 4.15 (Air 20) or 4.16 (Air 25). Using my distribution certificates, building the app completes and gives me an .ipa file which in the past I then copied to Tunes and installed on my ipad for final testing before uploading to iTunes connect. But now when I copy the app to iPad from iTunes it gets part way through the installation then fails. The app icon is removed and the app never installs. The sweeping progress indicator gets part way round then the icon disappears. This happens using Flex 4.15 and 4.16 SDKs.

Using my development certificates, a development build runs on iPad using Flex 4.15. When I use Flex 4.16, the app opens but then promptly shuts down before anything happens. In debug mode all I get is that the swf files are decompressed ... there's no other indication of the problem.

The app runs in the simulator using Flex 4.15 and 4.16.

The app itself isnt broken, as there have been no code changes to the release that's live on the store on the store. And it runs on ipad using 4.15 in development mode and using both SDKs on the simulator.

Perhaps there are new iOS configuration settings required in the app.xml descriptor which have to be updated for iOS 10.3.2?  Alternatively I am concerned to see Flex 35277 issue "Apps created using Flex crashes on iOS". So do I have this problem?

I'd be grateful to hear if anyone has any ideas ... thanks!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Flex iPad app no longer installs

Erik J. Thomas
Hi Robert:

I'm a little confused since you mention at least three different problems. I'll try to address the first since if you fix this, you will likely fix the other problems.

> My Flex iPad app (equationlab.net) no longer deploys to iPad with iOS 10.3.2
> from FlashBuilder 4.7 using Flex 4.15 (Air 20) or 4.16 (Air 25).


My first question would be: does it deploy and run on an iPhone? If so, it's likely your AdHoc provisioning profile doesn't include support for your iPad device.

Regardless, for debug/run modes from FlashBuilder (connected via USB), first visit Apple Developer site and ensure:
Your certificate is not expired.
Your provisioning profile includes support for your specific iPad. Go to All Devices view and look for your iPad add it if not there, then edit your provisioning profile and ensure your iPad is selected and re download the profile, replacing your old one.
Your provisioning profile is Ad Hoc (not development).

But whether you are installing from FlashBuilder in debug/run mode, or installing from iTC using TestFlight you can view the console log output to learn of root cause. I use the console fairly often and it's been invaluable.

This is probably the best free iOS console app out there and comes highly recommended in the Apple developer community:

https://lemonjar.com/iosconsole/ <https://lemonjar.com/iosconsole/>

The iPad needs to be connected to your Mac via USB cable for this to work. Just filter the iOS console on the text "install" to view the root cause of the failure which is likely a certificate or provisioning profile problem but it could be a number of other issues. If you save the output (try to clear before you install and unplug immediately after the failure so the log isn't gigantic, then you can attach the log to your subsequent post to this user group.

Anyway, get this working and your TestFlight install may also be fixed, but remember to use the right provisioning profile type for iTC. You need an App Store provisioning profile for that, not Ad Hoc. And of course, you never using a Development profile with FlashBuilder.

One last thing: do yourself a favor and dump FlashBuilder 4.7. It's unsupported and hasn't been updated in years. IntelliJ is a first-class IDE for Flash/Flex development and I find it WAAAAYYYY easier and better than FB, especially for mobile development, and it's fully supported, with really great tech support folks, tons of docs, and upgrading SDKs is about 10 times simpler than updating SDKS with FlashBuilder. You don't have to patch the SDK inside of FlashBuilder. Just install the SDK with AIR to any directory you want, then open it the folder in IntelliJ and assign it to your project modules.

https://www.jetbrains.com <https://www.jetbrains.com/>

Erik

> On Jul 9, 2017, at 8:28 AM, robertB <[hidden email]> wrote:
>
> Has anyone else had this problem and can point to where I should look for a
> fix?
>
> My Flex iPad app (equationlab.net) no longer deploys to iPad with iOS 10.3.2
> from FlashBuilder 4.7 using Flex 4.15 (Air 20) or 4.16 (Air 25). Using my
> distribution certificates, building the app completes and gives me an .ipa
> file which in the past I then copied to Tunes and installed on my ipad for
> final testing before uploading to iTunes connect. But now when I copy the
> app to iPad from iTunes it gets part way through the installation then
> fails. The app icon is removed and the app never installs. The sweeping
> progress indicator gets part way round then the icon disappears. This
> happens using Flex 4.15 and 4.16 SDKs.
>
> Using my development certificates, a development build runs on iPad using
> Flex 4.15. When I use Flex 4.16, the app opens but then promptly shuts down
> before anything happens. In debug mode all I get is that the swf files are
> decompressed ... there's no other indication of the problem.
>
> The app runs in the simulator using Flex 4.15 and 4.16.
>
> The app itself isnt broken, as there have been no code changes to the
> release that's live on the store on the store. And it runs on ipad using
> 4.15 in development mode and using both SDKs on the simulator.
>
> Perhaps there are new iOS configuration settings required in the app.xml
> descriptor which have to be updated for iOS 10.3.2?  Alternatively I am
> concerned to see Flex 35277 issue "Apps created using Flex crashes on iOS".
> So do I have this problem?
>
> I'd be grateful to hear if anyone has any ideas ... thanks!
>
>
>
>
> --
> View this message in context: http://apache-flex-users.2333346.n4.nabble.com/Flex-iPad-app-no-longer-installs-tp15434.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Flex iPad app no longer installs

robertB
Hi Erik

Thanks so much for your very comprehensive and generous reply.

Using an Ad Hoc provisioning profile rather than distribution solved the problem of the app not installing. I don't recall having to do this last year ... maybe Apple have changed this and separated out ad hoc and distribution. Anyway, that sorted it.

My Flex 4.15 build runs OK but the Flex 4.16 build crashes on launch. My best guess and next step is to upgrade to the latest versions of Milkman Games' GoViral and StoreKit which I use. I think the most recent one of these if for Air 25 so that's most likely what is causing the problem.

Thanks too for the pointers on IDE and console. Really helpful Erik.

Many thanks  
Loading...