Error deleting batik lib contents during build

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Error deleting batik lib contents during build

kamcknig
Building the SDK appears to fail in the batik-jars target of the
modules/downloads.xml build file.

unzip-file:
    [unzip] Expanding: D:\apache\flex\flex-sdk\in\batik-src-1.7.zip into
D:\apache\flex\flex-sdk\in

copy-downloaded-jar:

BUILD FAILED
D:\apache\flex\flex-sdk\build.xml:158: The following error occurred while
executing this line:
D:\apache\flex\flex-sdk\modules\build.xml:64: The following error occurred
while executing this line:
D:\apache\flex\flex-sdk\modules\downloads.xml:265:
java.nio.file.InvalidPathException: Illegal char <*> at index 53:
D:\apache\flex\flex-sdk\modules\thirdparty\batik\lib\**
        at
java.base/sun.nio.fs.WindowsPathParser.normalize(WindowsPathParser.java:182)
        at
java.base/sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:153)
        at
java.base/sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:77)
        at java.base/sun.nio.fs.WindowsPath.parse(WindowsPath.java:92)
        at
java.base/sun.nio.fs.WindowsFileSystem.getPath(WindowsFileSystem.java:229)
        at java.base/java.io.File.toPath(File.java:2290)
        at
org.apache.tools.ant.taskdefs.Delete.isDanglingSymlink(Delete.java:879)
        at org.apache.tools.ant.taskdefs.Delete.execute(Delete.java:642)
        at
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:292)
...
...

It appears ** is not valid in the dir attribute of delete maybe?

I think I can just change the value to "${basedir}/${batik.dir}/lib" but
wanted to post here to be sure of the intention of that target and if this
is an error on other systems?

Kyle



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Error deleting batik lib contents during build

kamcknig
For additional info as well I am building from the 4.15.0 tag

Kyle



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Error deleting batik lib contents during build

Alex Harui-2
Reply | Threaded
Open this post in threaded view
|

Re: Error deleting batik lib contents during build

kamcknig
Hello,

I am using the latest Ant from the Apache site: 1.10.5

Thanks,
Kyle



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Error deleting batik lib contents during build

Alex Harui-2
Hi,

I'm using 1.9.4.  Can you try that version?  What version of Java are you using?  I wonder if Ant 1.10.5 is more sensitive.

HTH,
-Alex

On 4/18/19, 11:22 AM, "kamcknig" <[hidden email]> wrote:

    Hello,
   
    I am using the latest Ant from the Apache site: 1.10.5
   
    Thanks,
    Kyle
   
   
   
    --
    Sent from: https://nam04.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-flex-users.2333346.n4.nabble.com%2F&amp;data=02%7C01%7Caharui%40adobe.com%7C494d3319fed145e0d2e108d6c42acb58%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C1%7C636912085422183411&amp;sdata=YI6U31AjS5Zh4bVhJNyY6dCx57BOXFJdwbV9Y5bmv7U%3D&amp;reserved=0
   

Reply | Threaded
Open this post in threaded view
|

Re: Error deleting batik lib contents during build

kamcknig
For Java I am using Amazon's Corretto 11.

I did get it to work just by removing  the ** so I'm OK not finding the
answer to this at this point since I was able to get it to work.

I did have another problem downloading some of the files during the build
now but I'll start another thread for that after researching if those URLs
have been updated since the 4.15.0 tag and maybe it's just the old tag that
has bad URLs

Thanks!
Kyle



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Error deleting batik lib contents during build

piotrz
Hi Kyle,

I'm wondering why are you trying to build 4.15.0 tag instead develop with
newest version ?

Thanks,
Piotr

pt., 19 kwi 2019 o 13:13 kamcknig <[hidden email]> napisał(a):

> For Java I am using Amazon's Corretto 11.
>
> I did get it to work just by removing  the ** so I'm OK not finding the
> answer to this at this point since I was able to get it to work.
>
> I did have another problem downloading some of the files during the build
> now but I'll start another thread for that after researching if those URLs
> have been updated since the 4.15.0 tag and maybe it's just the old tag that
> has bad URLs
>
> Thanks!
> Kyle
>
>
>
> --
> Sent from: http://apache-flex-users.2333346.n4.nabble.com/
>


--

Piotr Zarzycki

Patreon: *https://www.patreon.com/piotrzarzycki
<https://www.patreon.com/piotrzarzycki>*
Reply | Threaded
Open this post in threaded view
|

Re: Error deleting batik lib contents during build

kamcknig
In reply to this post by kamcknig
Hi there, Piotr!

The project I'm working on is using it and they don't want to update yet
(we're even still using AIR 20.0 instead of 32.0 ). I'd like to make some
changes to the source and didn't want to just copy the class over to our own
project and change it there. I also like to tinker/play/learn so was doing
it for my own edification as well.

Kyle



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Error deleting batik lib contents during build

Alex Harui-2
In reply to this post by kamcknig
OK, that probably explains why we didn't see it earlier.

Feel free to submit your changed downloads.xml as a patch or pull request.

Thanks,
-Alex

On 4/19/19, 4:14 AM, "kamcknig" <[hidden email]> wrote:

    For Java I am using Amazon's Corretto 11.
   
    I did get it to work just by removing  the ** so I'm OK not finding the
    answer to this at this point since I was able to get it to work.
   
    I did have another problem downloading some of the files during the build
    now but I'll start another thread for that after researching if those URLs
    have been updated since the 4.15.0 tag and maybe it's just the old tag that
    has bad URLs
   
    Thanks!
    Kyle
   
   
   
    --
    Sent from: https://nam04.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-flex-users.2333346.n4.nabble.com%2F&amp;data=02%7C01%7Caharui%40adobe.com%7C2b02ca74c1b74378067008d6c4b82085%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636912692430449003&amp;sdata=O92QSC8kzy5DF8ndPnJVVZKl%2BOSqG4GthwZ2cCabRaw%3D&amp;reserved=0