ADT incompatible with iOS 13?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

ADT incompatible with iOS 13?

Erik J. Thomas
Hey all:

I updated my iPhone devices to iOS 13 last week and while I'm not sure this is the issue, for some reason ADT will not connect to my devices anymore to install my development app when doing a Run or Debug session from IntelliJ.

Of course this has nothing to do with IntelliJ since it simply shells out to ADT, but the ADT command to install the app fails every time. I've included some information about what I've tried to no avail.

Has anyone else run into this issue? I'm running AIR 32 and I can still run/debug local app on Android devices, just not iOS.

Thanks.

Erik

Steps to reproduce:
  1. USB tether the iOS device to a Mac running IntelliJ IDEA for Flex development.
  2. Initiate a Run or Debug session.
Expected results:

App is built, iOS package is created, and installed on the device.

Actual results:

App is built, iOS package is created, but while ADT is attempting to install on the device, it fails:

Best Hints:

Opening the recent logs for the Run / Debug session I see no explanation of what is wrong (see below log output), but the iOS console logs may indicate something of value:

default 09:33:32.049636 -0700 rapportd CLink: Found CUBonjourDevice 94:E2:DB:D0:CB:30, 'Eriks Linqto Laptop'
...
default 09:33:32.171674 -0700 rapportd CLink: Lost CUBonjourDevice 86:72:0A:1D:90:23, 'Eriks Linqto Laptop'

I don't recognize anything else in the iOS console output as being related to this issue. If you need full logs, I can attach them to the issue.

What I've tried:

  • Restarted IntelliJ.
  • Restarted the iOS device(s).
  • Restarted the Mac.
  • Cleared caches and restarted IntelliJ.
  • Researched ADT command line options to see if there is a -v (verbose) setting that will provide more information about the failure. Nothing available I could find.
  • Ran XCode console to view installd or any process containing our bundle ID. It appears that when ADT is connecting to the device to install the app, the device loses its connection. 
  • Switched USB/Lightning cable between device and computer.
  • Switched USB port on computer where the cable is connecting to the device.
  • Tested both iPhone 8, and iPhone X.

So far I have not been able to find a solution. Do you have any suggestions? Following are logs for both IntelliJ and XCode console:

HERE ARE THE INTELLIJ LOGS RELATED TO A RUN SESSION:

2019-10-14 09:06:55,996 [4360715]  DEBUG - ript.flex.actions.ExternalTask - [1637622198] Executing task: /Applications/IntelliJ IDEA 2018.2.app/Contents/jbr/Contents/Home/bin/java -Dapplication.home=/Users/ethomas/linqto/FlexSDKs/SDK4.16.1-32-43 -Dfile.encoding=UTF-8 -Djava.awt.headless=true -Duser.language=en -Duser.region=en -Xmx1024m -jar /Users/ethomas/linqto/FlexSDKs/SDK4.16.1-32-43/lib/adt.jar -devices -platform ios 

2019-10-14 09:06:57,380 [4362099]  DEBUG - ript.flex.actions.ExternalTask - [1637622198] Process output: List of attached devices:
Handle DeviceClass DeviceUUID DeviceName
 349 iPhone   7106c07ee312794b64790f18777cf1397ff6c44d Erik’s iPhone X
 
2019-10-14 09:06:57,417 [4362136]  DEBUG - ript.flex.actions.ExternalTask - [190529528] Executing task: /Applications/IntelliJ IDEA 2018.2.app/Contents/jbr/Contents/Home/bin/java -Dapplication.home=/Users/ethomas/linqto/FlexSDKs/SDK4.16.1-32-43 -Dfile.encoding=UTF-8 -Djava.awt.headless=true -Duser.language=en -Duser.region=en -Xmx1024m -jar /Users/ethomas/linqto/FlexSDKs/SDK4.16.1-32-43/lib/adt.jar -installApp -platform ios -device 349 -package /Users/ethomas/linqto/FlexDev/InvestorID/out/debug/globalinvestorid.ipa 

2019-10-14 09:07:00,066 [4364785]  DEBUG - ript.flex.actions.ExternalTask - [190529528] Process output: Error connecting to your device!

HERE ARE THE IOS CONSOLE LOGS RELATED TO THE MOMENT OF INSTALL:

default 09:33:32.049636 -0700 rapportd CLink: Found CUBonjourDevice 94:E2:DB:D0:CB:30, 'Eriks Linqto Laptop'
default 09:33:32.050171 -0700 rapportd Bonjour peer changed <ced96af59b9a>: CUBonjourDevice 94:E2:DB:D0:CB:30, 'Eriks Linqto Laptop', 0x2 < Attrs >
default 09:33:32.051654 -0700 callservicesd Device changed: <private>
default 09:33:32.051766 -0700 callservicesd Updating nearby device routes using devices: <private>
default 09:33:32.052090 -0700 callservicesd Current calls do not support nearby devices (<private>) or device doesn't support primary calling (<private>)
error 09:33:32.052355 -0700 assistantd -[ADCompanionService _updateAssistantIDMapForDevice:] unable to find assistant identifier for device: <private>
default 09:33:32.168417 -0700 mDNSResponder [R26407->Q0] DNSServiceQueryRecord(<private>, TXT) RESULT ADD interface 8: (mortal)<private>
default 09:33:32.169052 -0700 rapportd Add without remove new:   Eriks Linqto Laptop._companion-link._tcp.local.%8: rpHN=ab13a044e7cc | rpFl=0x20000 | rpVr=174.23 | rpHA=1fe2d0de39af | rpAD=fa673ffe250c | rpHI=e6660d8b7a2c | rpBA=94:E2:DB:D0:CB:30
default 09:33:32.169350 -0700 rapportd Add without remove old 1: Eriks Linqto Laptop._companion-link._tcp.local.%8: rpHN=07295f3bfcf8 | rpFl=0x20000 | rpVr=174.23 | rpHA=8cd2e899d771 | rpAD=41ed9641e341 | rpHI=7ab5834225b7 | rpBA=86:72:0A:1D:90:23
default 09:33:32.169535 -0700 rapportd Add without remove old 2: Eriks Linqto Laptop._companion-link._tcp.local.%8: rpHN=58dd282622ef | rpFl=0x20000 | rpVr=174.23 | rpHA=a5264c4ba716 | rpAD=05598fd02fd8 | rpHI=879ca58756fd | rpBA=87:D1:8A:6E:F5:F9
default 09:33:32.169919 -0700 rapportd Add without remove old 3: Eriks Linqto Laptop._companion-link._tcp.local.%8: rpHN=d8dcf5e42a35 | rpFl=0x20000 | rpVr=174.23 | rpHA=47e60d41c113 | rpAD=4512e6a2e7fb | rpHI=a8aa52ccb948 | rpBA=39:02:31:32:4A:FC
default 09:33:32.170318 -0700 rapportd Add without remove old 4: Eriks Linqto Laptop._companion-link._tcp.local.%8: rpHN=795cde49d56d | rpFl=0x20000 | rpVr=174.23 | rpHA=108e9e1a0f9f | rpAD=2a2defbdc572 | rpHI=ca75d21dc9b0 | rpBA=43:F6:83:2D:C8:0F
default 09:33:32.170770 -0700 rapportd Removing and re-adding Eriks Linqto Laptop._companion-link._tcp.local. for TXT device ID update (86:72:0A:1D:90:23 -> 94:E2:DB:D0:CB:30)
default 09:33:32.171458 -0700 mDNSResponder [R26407] DNSServiceQueryRecord(404000, 8, <private>, TXT) STOP PID[76](rapportd)
default 09:33:32.171674 -0700 rapportd CLink: Lost CUBonjourDevice 86:72:0A:1D:90:23, 'Eriks Linqto Laptop'
default 09:33:32.171867 -0700 mDNSResponder mDNS_StopQuery_internal: NumAllInterfaceRecords 60 NumAllInterfaceQuestions 5 <private> (TXT)
default 09:33:32.172325 -0700 rapportd Bonjour peer lost <ced96af59b9a>: CUBonjourDevice 86:72:0A:1D:90:23, 'Eriks Linqto Laptop'
default 09:33:32.172495 -0700 rapportd 44: Peer present changed: yes -> no
default 09:33:32.172918 -0700 rapportd CLink: Changed CUBonjourDevice 94:E2:DB:D0:CB:30, 'Eriks Linqto Laptop' 0x1 < Attr >


Message protected by MailGuard: e-mail anti-virus, anti-spam and content filtering.
http://www.mailguard.com.au

 
 
Reply | Threaded
Open this post in threaded view
|

Re: ADT incompatible with iOS 13?

leokan23
This is a known issue with the current AIR versions. I think it is solved in
AIR 33 previous version (AIR 33.0.2.281)

"AIR-242: Updating iIPA tool to ensure packages can be installed onto iOS 13
devices [didn’t work]"

Maybe you can give it a try.



--
Sent from: http://apache-flex-users.2333346.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: ADT incompatible with iOS 13?

Erik Thomas-2
Thanks for your reply, Leokan. I did some research since posting this question and found that Harmon is working on this fix in a future build of AIR 33 but as of this week it still wasn't available.

I'll be watching for that fix before we have to start paying Harmon for the Enterprise license. We're holding off as long as possible. Unfortunately our revenues put us into the Enterprise category, even though we are a startup and haven't made a profit yet.

We have our apps in the stores so we don't need to get 64 bit Android builds until August 2020 and we will squeeze every drop out of AIR 32.

Erik